Mobile/data recently stopped working


Long story short, got the 2e sometime last january new (so I guess it’s the 2022 version). Transferred my sim from the old phone to the new and everything works fine for several months.

Sometime in the last month or so, data has stopped working. Calls (incoming and outgoing) still work fine, as do texts. But nothing installed can access data (chrome, reddit, gmail, twitter, authenticator, play store and youtube, all dead), unless wifi is connected.

I don’t have any custom rom installed. There are very few apps installed, I keep it very minimal. I basically haven’t installed or uninstalled anything since that first week I got it in january. Aside from automatic updates to the above listed apps, and anythign pushed by the OS/teracube, for all intents and purposes it should be the same.

I have tried putting the sim card back to my old phone, and on it data works. Put it back in the e2, data no longer works. Carrier is telus.

Short of a factory reset, is there anything I can try?

Contacting telus will be my next step if all else fails. Since I basically can assume that once they know what phone I’m using, they’ll say something along the lines of “we don’t support that phone, try one of ours instead”, which is why I’m asking here first.

Hi @muki - let’s try a network reset. Goto Settings > System > Reset options > Reset WiFi, mobile, and Bluetooth

If this doesn’t work, then please call Telus to see what they have to say. You can always “pretend” to have a supported Android like a Pixel or a Motorola phone to avoid derailing the conversation.

Hi! Thanks for the reply. I’ve tried the network reset and alone it didn’t fix the issue. However I found progress and a sort of workaround, even though it might not be fully fixed.

I’ve found that if I go to settings → Network and Internet → Mobile network (TELUS) → Preferred network type (4G recommended) and change it from 4G to 3G, data starts working again. Then if I change it back to 4G, data keeps working! If I restart the phone after this “fix”, then data no longer works and I have to do the switch and switch-back again.

I’ve tried this a few time the last couple days and the pattern is the same. I don’t really know why this is. I live in a high density city with a lot of coverage.

I had that happen on a BB, it turned out that I had a data limit set at a very low level and no warning set.