Ongoing data issues with 2e and Telus

A year ago I posted this thread about spotty data. The only fix I could find that worked was to switch/toggle between 4G and 3G under prefered network type every time I wanted to use data. Thankfully that isn’t mroe than once a day or so, so I kind of got in the habit of fixing it this way. Despite being a shoddy workaround.

In the last few days data has alltogether stopped functionning. No matter what network type I try.

Have tried resetting mobile/wifi/bt settings. And restarted phone.

Have tried swapping the SIM between the two slots. I shut down and restart the phone between swaps to be sure.

Calls and messaging work fine. As does data if I have it connected to WIFI. The data issues are only when I’m trying to use mobile data.

Phone is not rooted. I don’t play games or install a whole lot on it. Just phone necessities, email, MS authenticator, firefox, those sorts of basic things.

I found this post (and others like it) that say I should try setting/resetting APN settings. Telus have also told me I should make sure the phone is using these settings (under change your APN settings). And to check with the phone manufacterer if I still have issues.

So I checked the APN settings. Those settings on the phone (settings->mobile network->advanced->access point names->edit) all appear to be identical to the Telus page. But still no data.

What should I try?

1 Like

Sorry for the frustration around this.

Can you tell us what version of Android you’re using on your 2e? It will be in the Settings under System.

1 Like

Hi! Thanks for the reply.

Android 11, security update oct 5 2021
and build number Teracube_2e_A11_05_selftest if it matters

settings->system->updater says that the device is up to date.

1 Like

Perfect, exactly what I needed to know, so thank you.

Would you be willing to manually load our latest Beta release to see if the fixes present in it help your situation?


I can try the beta release later this week/weekend yeah. I just need to make a backup first.
To be continued.



No rushing you from our end, just wanted to see if this is something that may help you in the near-term while the team works on further updates.

1 Like

So over the weekend I flashed the latest beta linked to in that other thread, and I think that’s fixed my data issues! Been using it for 2 days and it seems good so far. Hopefully it sticks!

Thank you for the help!


Sweet, glad you’re up and running!

Yeah, fixes for connectivity was one of the main focuses for this latest round of Betas, so it is nice to hear that it is helping folks.

1 Like