My phone is killing longer running apps

What can I do to stop my 2e to kill long running apps? For example it seems constantly killing my Signal app, so that it updates messages only when I open the app. And several other apps which need to run constantly.

I completely switched of the Battery-Manager (“Akku-Manager” in my German language version) and also “DuraSpeed” is inactive. In addition I have excluded the needed apps from power optimization (“Akku-Optimierung”) also individually.

Would be great to get some advice what might be the problem here.


1 Like

This is a balance between allowing apps to run in background vs battery. Mediatek has provided us the Duraspeed code underneath which does kill apps even when the feature is not enabled (yupp - a bit counterintuitive).

Could you try the thing suggested in this post:

Thank you Sharad for this advice. I did as suggested and I now hope for luck. :slight_smile:

1 Like

oh god is that what’s going on? Y’all should yell at Mediatek about that, so that their Duraspeed stuff is totally out of the way (inactive, logically muted) if it’s disabled… I really think it’s unscientific if they leave parts of its implementation dangling around the OS when it’s switched off, as it’s impossible to make a proper A/B comparison to see if the feature is even worth enabling.

I have similar complaints - apps lose their notification abilities if I don’t actively open those apps regularly.

Might need to try activating it, then, and just working with it…

Yes, exactly this is my issue! And I now enabled Duraspeed, selected every application to be excluded and now at least my Signal app is working as expected. For a day now. Continueing with hoping…

Duraspeed definitely appears to be the culprit here.

I’ve had a handful of apps whose notifications and functions didn’t work properly unless I opened each one every day. Then they would ask me to approve certain permissions every time which I would, then I’d have to do it all over again the next day (“Call Recorder” and “Eufy Security” as a couple examples).

After reading this thread I went in and actually turned Duraspeed on. All the apps on its list were defaulted to off, so I went through and turned on the various apps that I’d been having trouble with and they are now functioning normally.

I didn’t think it was legal for an app to say it’s off but still be working in the background - especially when that app is apparently able to affect the function of other apps. That seems a little slimy on Duraspeed’s part, and it seems like a potential security risk. What else is it doing behind the scenes?

1 Like

Yes, certainly I see this as a critical bug.
I turned Duraspeed on, selected all applications to be excluded and in the meantime I also switched Duraspeed off again. My apps all now seem to run as they should. That’s good. :slight_smile:

Duraspeed is all about battery and performance management by killing apps in the background.

Yeah and that’s fine - it’s more that it was killing apps in the background even when it was completely turned off. It shouldn’t do anything when it’s off.


Correct. Our Dev team is looking into both - either fixing that bug in Duraspeed or using an alternate solution.


this is also why ring and other apps are not notifying. i dont want to use duraspeed at all. this should be an option we can remove or leave off without it doing anything if its off.

How’s the progress going on this? Just curious since I’m missing notifications every day. What kinds of challenges are you facing on this? :slightly_smiling_face:

Just to confirm - have you already tried the suggestions in this post? That should get your notifications to work. Basically do both these steps:

  1. Disable battery optimization for whatever app is missing notifications.
  2. Enable Duraspeed and whitelist all apps or the apps having issues.

If you have done this already - could you tell which apps are missing notifications?

Hey Sharad,

I just turned on Duraspeed and whitelisted all the apps I need. So far so good.

1 Like

I’m experiencing an issue where apps are being killed while I’m in the middle of using them. I contacted support about this, and eventually they directed me to this thread. So I tried whitelisting all the affected apps on Duraspeed and turning off battery optimization for them. That seemed to work for a time, but it started happening again. I’ve verified that the Duraspeed and battery optimization settings are still what I set them to. I let support know that it was still happening but haven’t heard back yet.

It makes some apps practically unusable, even though they worked just fine on the first Teracube model. I’ve tried closing all other running apps, running them while the phone is plugged in, and even running them while battery saver mode is on. Still no luck. Has anybody else experienced this?

Could you list some of the apps and repro steps? Also - could you take a screen capture video of this happening (using AZ screen recorder).