Need Help: 2e Black Screen and Unresponsive

A couple weeks ago my teracube 2e suddenly black-screened and has been unresponsive since. I wasn’t using it at the time of failure, just pulled it out of my pocket and found it unresponsive. The backlight turns on and off when connected to power, but the screen stays black. Weirdly, one of my alarms went off the morning after this happened. Phone was still non-responsive so I took the battery out to turn it off. Haven’t reproduced that since.

Because of the alarm thing I assumed there was some kind of damage to the screen or display cable causing the problem, so I ordered a new screen and replaced it, but nothing changed.

I’m now trying to do a factory reset using the helpful guide but I can’t get my pc (Windows 11) to acknowledge the phone via usb cable. I get a “USB device not recognized” error message whenever I plug it in. I’ve tried multiple cables and several different known-good usb ports but the same result. Because of this I can’t use SP Flash. Any tips/advice on how to proceed from here would be much appreciated. Is there any way to at least wipe my data from the device in this state (drillbits and hammers excluded?)

Important info: I don’t have developer mode enabled, unfortunately. I did put the battery back in after taking out after the alarm nonsense: backlight still comes on so it’s still powered.

1 Like


Sorry for the frustration.

Do you have a machine with Linux, or at least the ability to install/usage commandline tools on that machine?

You could try using adb/fastboot to see if the unit is even working enough for the bootloader to talk over USB, if so, you can wipe it that way.

If not, there is really not much you could do at this point in time to ensure data is not accesible that isn’t physically breaking the storage since you do not have display, (likely) touch input, USB access for SPFlash, nor ADB already enabled for headless access.

Thanks for the advice, I’ll see what I can do with adb

1 Like