NFC and Google Pay

Has anyone been successful using Tap-to-Pay via the Google Pay app and NFC?

I’ve tried a few times unsuccessfully at Trader Joes and once at Target. NFC was on and I checked all of the NFC and Google Pay settings so ensure everything was enabled.

It seemed like no NFC messages were exchanged. With my old phone, there were many problems getting this going, but typically it gave me errors during the process. In this case, nothing happens.


I have been able to use NFC/Google pay. So far I have used it twice, Walgreens and Whole Foods. Maybe try deleting your info from Google Pay, reboot the phone, then add your info back in.

I also can’t get NFC tap to pay to work, and I believe I’ve configured Google Pay correctly, as I’ve done for other phones in the past, though Google’s new version may be different somehow. I’m not likely to delete the data/app and retry just because getting my bank’s authorization to use my card is a huge pain since I have to do it by phone during business hours.

Hi @brianary - welcome to Teracube forums. Could you check the following:

  1. Is your bootloader unlocked? Google Pay will not work if the bootloader is unlocked
  2. Does the Google Pay give any error while setting up or when trying a transaction?
  3. Is your NFC enabled? (check in quick settings by dragging from the top)
  1. No, not unlocked
  2. No errors, but I’ve only tried a couple times in situations where I didn’t have a lot of time to try. I’ll try a few more times in other places.
  3. Yes, it shows enabled, though “card emulation” shows as “Off,Off” until I tap into it, where it says it’s “On”. If I turn it off, it then says “Off” (just once).

Still no errors or anything, but I can definitively say NFC payment doesn’t work.

Are you on Android 9 or Android 10? Did it work before or is this the first time you have tried?

If on Android 9, could you install the new Android 10 build and try again?

Since this is my first phone with Android 10 and the new Google Pay, I’ve noticed that it looks like I have to both open the app and tap the card (previously I didn’t need to do either), so I need to try one more time, apparently.

Even from the “Hold to reader” screen, contactless payment isn’t working. The POS NFC reader makes clicking sounds, but nothing happens beyond that.

Could you do a factory reset and try again please. If it still does not work, then we might have to do a warranty replacement. You can get started by sending an email to after trying a reset.

Setting up a new phone usually takes me about a week, since I’ve got hundreds of apps installed from several app stores, and reconfiguring, restoring, and authenticating them takes quite a while. Also, as mentioned, my bank is pretty tedious to set up Google Pay for. A factory reset will be pretty involved.

I got my Teracube in anticipation of some travel I’ll be doing in August, if that’s a reasonable time frame.

I did a factory reset, declined the app & data sync to keep things minimal, and added a card from a financial institution that was able to add it immediately, then I tried again at two different retailers with Google Pay open to the payment card (“Hold phone to reader”), but it still didn’t work. I’ll contact support.

Epilogue: Solved!

One of the pogo pins inside the back of the phone was stuck and not quite reaching the metal contact on the inside of the back. One I’d gently unstuck the pin, everything started working.

Tip: Testing NFC is way easier using Android Beam with another phone than driving to the store to retry Tap to Pay a dozen times.

1 Like