Nfc not working

Hi, today I was trying to validate a ticket by tapping it on a tag in the bus to no avail. The app is Seamless, the ticket is a day pass for bus, ferry and cable car in Toulon, France. No google pay etc. involved, the app is supposed to charge me via visa card info that i provided earlier. It worked fine on my son’s huwawei but didn’t on my teracube2e. Nfc was on, all the necessary permissions were given. Could there be anything wrong with the nfc antenna? thnx, Axel

Is there a way for you test the NFC with some other app? There are some really cheap NFC tags that you can buy on Amazon and test with this app -

Dear Sharad,
I have tested the NFC with multiple apps and tags. Also, I used my ID App and my German ID, which has a built-in NFC tag and is fail-safe. This is a necessary way to log in and communicate with various governmental departments here in Germany. It worked with my old phone but doesn’t with my teracube - which is not good because I cannot verify my accounts mentioned above and have to roll back to the ‘analogue’ mode of sending everything per mail. What to do? Another replacement with early shipping? Probably. But it’s such a drag because I’d have to yet again install everything on the replacement…

Just to confirm - is the NFC on T2e working with your tested tags? If its working with test tags, then the NFC antenna and software is most likely working well. You could confirm by doing a soft or a full reset.

Sorry, maybe I wasn’t clear enough. The NFC IS NOT WORKING with any of the tags and apps I’ve been using so far: Public transport and tags on buses in Toulon, my ID tag, etc. I just don’t think a full reset will get me there… but I’ll do that anyway and let you know whether anything’s changed after that.

Thanks for clarifying. If it’s not working after the reset, please reach out to the team for a replacement.