NFC not working?

I want to use the phone to read my blood sugar monitor. (Freestyle Libre). It should read with the NFC. When I search for NFC in the search bar in settings, it shows 3 things - the app/software, and two items that seem to be about preferences, as far as I can tell in the small print under it. When I click either one, it brings me to Connection Preferences, and NFC isn’t listed there at all. Looking in the App Info, permissions are greyed out. When I launch the Freestyle Libre app, it crashes immediately, and I’m wondering if it’s something with the ?lack of? NFC. What can I do to use this? This was the entire reason I decided to buy the phone, due to it having an NFC that I could use with this to help monitor my diabetes without having to carry the reader that comes with it.


1 Like

The TeraCube most decidedly does have NFC, so that is odd. As I commented in your other thread, please try a Cache Parition reset first. If that doesn’t resolve it, a fully device reset will be next in order. Finally, if that isn’t a solution, there might be a lower-level firmware or hardware issue with your specific device.

Please try to clear the Cache partition first as per the Guides here:
How to reboot into Safe mode (for troubleshooting)

How to clear/wipe cache partition

If that fails and you’re certain you’re on the most recent Device Software, I’d recommend a factory reset (you will lose all data/information):
How to factory reset (Erase all user data)

1 Like

NFC settings should be available under Settings > Connected devices > Connection preferences > NFC. Make sure all of the settings are enabled under NFC.

If you are not finding NFC or are still not able to get it to work with Freestyle Libre, then you can try the following:

  1. Check to make sure you have SW6 software build (here).
  2. Enable sound and vibration both under Freestyle Libre app settings as mentioned in this thread.
  3. Clear your cache partition as suggested by @Saijin_Naib
1 Like

I have wiped cache. Here is what I see:


The freestyle libre app also has permissions greyed out, like the NFC app as I show above. I have not yet reset.


Yeah your NFC settings are missing. Lets try a factory reset. If that does not work, email us at so that we can do a warranty replacement for you.

Ok, Factory reset has produced?revealed? NFC in the above mentioned settings page. It still says ‘no permissions requested’. The LibreLink app also launches now, but doesn’t seem to read anything, shows ‘no permissions requested’, and I can’t tell from the playstore page whether it should be asking for any, so I’m rather confused. So while I do see the nfc in settings, the only thing that’s off is ‘card emulation’ (and I don’t know what that is), I can’t tell if it’s actually working.

I expect I should also pursue this with the app people, but I’d be grateful if you folks have any suggestions.

Thanks for your help so far!

1 Like

Ok. I went to the ATT store today, and got a sim card for the phone, since the one I had in the BLU phone didn’t fit (micro). Now my Teracube doesn’t see the NFC card again, and firefox and librelink are crashing on launch. I’m assuming a(nother) factory reset won’t be a problem with the sim in place, but I figured I’d ask.

This is getting annoying. (Not annoyed at you folks, but technology. At least, so far.)

1 Like

Pardon me if you have confirmed this already - does your phone have SW6 update?

Factory reset with the SIM inserted is perfectly fine. If this issue persists, we can do a warranty replacement to take care of a potential hardware fault.

Yes, I have that build.

I was just enjoying having a phone again for a while; that’s why I was delaying trying another factory reset after getting the Sim card. I’ve already sent my previous phone off to be repaired.

Device reset got the NFC back. The play store page for the freestyle libre app lists a bunch of permissions that it may request. The app info page on the phone says no permissions requested. (As opposed to no permissions granted.). I have no idea if this is normal, and I haven’t found out where to even look for that information yet.


1 Like

Found this article and discussion thread below it -

Few comments stand out for me:

April 11, 2020 at 3:20 pm I love the app however after reading the blog where it states it works with the Freestyle Libre. So I followed the directions for the app to read via NFC and was surprised that it is not compatible with the US 14 day sensor.

The integration of the Libre is a great thing. Unfortunately, the scan often does not work the first time. The app needs to be shot through the task manager and reopened for the scan to work. Nevertheless, the app is very successful and by far the best diabetes app on the market.

November 15, 2018 at 4:40 am Could you check now I have a FreeStyle Libre 14 days and give error trying reading. Maybe the app needs an update?

March 14, 2019 at 2:27 am The new sensors being released in the US under the 14 day product line do not have the same internal firmware as the sensors released in the US under the 10 day product line. The new firmware can only be read by 14 Day Reader, or by the LibreLink app on compatible iPhones. It cannot be read by Diabetes:M, by Glimp, or any other software anywhere in the world.

March 14, 2019 at 2:29 am No, it will not. The sensors being released under the 14 day product line in the US have firmware which encrypts the NFC connection. No third party software, not Diabetes:M or any other product, can read it: only the Abbott LibreLink for iPhone, and the 14 day readers.

April 11, 2020 at 3:20 pm I love the app however after reading the blog where it states it works with the Freestyle Libre. So I followed the directions for the app to read via NFC and was surprised that it is not compatible with the US 14 day sensor.

Thanks for looking things up like that. I talked to Abbot tech support today, who tried to talk me through reading the sensor. I was unable to do it, waving all parts of the phone over it. They confirmed that the current version of the app that I have installed on the phone is the latest, and that it should work with the US 14day sensor. Among the things they asked me to do was turn the NFC off in the settings, wait a few seconds, and turn it back on again, and then relaunch the app and try. This did not help.

They asked me to find out where, in the phone, the NFC card is - closer to back or front, near the camera end or the charge end - and said that the phone nfc is often less powerful than the nfc card in the reader that comes with the system. They’re calling me back Friday afternoon (about 40 hours ish from when I’m posting this) to find out. I hope that you folks have time to reply by then - I do expect you’re busy! I did tell them that I expected that the phone was similar to other phones in that placement, as you expected it to be able to interact in the same way that other phones do.

I asked if there was some possible contact that I could point you folks to in order to get more detailed specs, or more information, and was told that they’re not the phone company. I’m not sure if they understood what I was asking.

I will be sad if this doesn’t work; apparently their desktop app doesn’t work for Linux, either, so I’m screwed either way.

I’ve not used the NFC features at all on previous phones. Is there some way I can test it out, to make sure that it’s working, in general?

Thanks for your continuing help!

I will let Sharad handle the technical details, but you can try this app top get information about functionality of NFC on your phone. You can also set up Google Pay and go to a place like McDonalds to see if it works.

NFC Check

1 Like

Can you try this simple app suggested by Debra - it tells the status of NFC on the phone. You can share a screenshot here.

I have just now ordered these simple NFC tags from Amazon (Receiving them Friday - will report if they are useful in testing NFC).

This is also a sure shot way of testing NFC. (Easy/difficult depending on Covid and other circumstances).

Yeah, the pay thing won’t work for me.
I don’t put money info anywhere, and not on a portable device that can get lost. (Yes, I have PayPal, I only access it on my wired desktop.) I don’t go out anyway, mobility impairment sucks. :confused:

I was reading over your full post and am wondering, as an interim step while you work on getting the app running on your phone if you could get the desktop Windows app to run on a Windows emulator in your Linux Distro. Here is a good, simple explanation of popular emulators, like Wine. You can find plenty of information online on how to install and use them. I would probably try Wine or Wine Staging.

Windows emulators

The phone’s NFC sensor starts about 4-5mm below the fingerprint scanner and extends 1.5inch further down towards the bottom.

Thank you, Debra. I have some experience with wine, mostly involved with installing World of Warcraft. Unfortunately I currently have some other health issues making analytical thought difficult. I’ll have to hope that someone else has worked on this already and posted it somewhere. I had hoped I wouldn’t have to do this. Apparently the fact that MacOS X + is Linux under the hood is either carefully kept from vendors, or they just don’t care.

Thanks, Sharad, I’ll let them know when I talk to them tomorrow.


Just to add info here, I received a call back from tech support. After confirming where the NFC card is, and that I’ve tried stopping/starting things, and tried every day to use the app, my case has now been escalated to IT and I’m going to get ANOTHER phone call. Is there some contact information I can give them in case they, for some reason, want to get in touch with someone on your end?

Also, my kid with the smart phone doesn’t have an NFC card. The other friends I’ve seen in the past 3 months don’t have smartphones. I really don’t want to do the google wallet thing. I realize that the NFC app mentioned by Debra says that everything is on, but that doesn’t confirm that anything else can see it. I’ll try to figure out how to test that also.

Thank you for all your help.

You can give them our toll free number : 877-728-2388. The team can forward the call to me as well if need be.

These NFC tags worked out of the box. There is a NFC Tools app that was able to scan the paper thin tag, write to it and do multiple tasks based on it.

1 Like