Pixel Experience

Did anyone try the Pixel Experience yet?
It looks promising.
Here some info about it:

“[ROM][11.0][UNOFFICIAL] PixelExperience for Teracube One [v7101o] | XDA Developers Forums”

1 Like


I tested it! And it’s flawless!
The only problem I had spinning Getting info for Google, but I fixed it by skipping the set up and going to Play Store and applying all updates.
Now that the bootloader is already unlocked, can I root it and not lose data?

1 Like

I would think so - just rooting should not wipe data. Other root experts can weigh in though. Unlocking bootloader is guaranteed to wipe data (as you already know).

Glad to hear your experience on a custom rom. Is VoLTE working? Other features?

1 Like

VoLTE is working fine.
I don’t see any issues yet.
I will keep you posted.


Can I perform these steps, down below, or everyone is specific to the OS and/or the build?

  • Perform Bootloader unlock steps (as above). Otherwise, the phone will complain of verification and will not allow you to proceed
  • Connect Teracube to your PC/computer using the USB-C cable came with the package.
  • Use platform-tools on your computer and run the command to flash the patched bootloader to your phone (your BOOT.IMG filename may vary)

fastboot flash boot teracube_patched_boot_sw1_magisk_20.4.img

  • Run the following command to complete reboot your phone and complete the process

fastboot reboot

I actually, already patched the boot.img into magisk_patched_DI9EX.img, but I was stuck in fastboot loop after that.
Anyone can help with rooting please?

I successfully unlocked my bootloader and flashed the PE recovery, but I’m stuck. I have the PE ROM downloaded, but adb can’t seem to locate it. Where do I need to put the .zip so adb will find it? Given my lack of knowledge, I recognize that I may have even that assessment wrong. I appreciate any help. Thanks!

1 Like

You need to extract the image from the zip file. The location doesn’t matter, provided you pass the full location to ADB properly.

Thanks Saijin - would that be the boot.img and/or dtbo.img? Then would it automatically pull in other files that were in the zip package?

I believe it’s boot.img

Easiest is to have the zip file in the same directory as your adb command. Then adb sideload <filename.Zip> should work.

1 Like

I followed the instructions, and it said my syntax was bad. I entered:

adb sideload <PE_v7101o.zip>

Am I missing something?


adb sideload PE_v7101o.zip

For some reason, now anything that depends on chrome I believe is showing up as blank. Not sure if it’s something related to Webview. I already tried clearing cache and data. No success. Any ideas on how to fix this please?

You might want to ask on xda forum as well

I already did and on Telegram channel as well. The reason I asked also here because, I’ve seen users having posts about the same issue with different devices and os.

Hi, have you tried factory reset? If possible, is there any chance you can take a short video of the symptoms?

These are some examples.
The preview look fine for the email, once I click on it, the body shows up as blank.