Poor gps signal

I have an issue with the GPS signal not working as it should. With my ancient phone I could perfectly use Runtastic without getting any issue with the localisation (and it was a 5 yo phone) but with my Teracube I can’t track my run anymore; the signal isn’t following my movements well : on the first pic, I ran for 45 minutes on the same trail as the second pic, and on the second pic, the best tracking signal I ever had, we can clearly see that the signal is not accurate at all (I was going back and forth on the trail). The worst is that I cannot have a realistic measure of the lengh of my runs anymore with this phone : in the first pic according to my teracube I ran 0.45 kms… :weary:
I know it is not an issue due to the Runtastic app because I used it before and it worked perfectly well.
What can I do ?

Are you using any fitness tracker band/watch along with the phone? Or is it just the Runtastic app running on Teracube? Reason I ask is we will try to replicate similar scenario here and see what happens.

No, It is just the Runtastic app running on the phone. I saw that the tracking is much better (but still looking like pic above) when I don’t put it to sleep, so I try to keep the phone “awake” (Idk the english term for that) during the session.

Android’s battery optimization can cause problems as well. Could you try removing it for runtastic app. Go to Settings > Apps & notifications > Special app access > Battery optimisation. Change filter to “All apps”. Then find your app (adidas runtastic) and select “Don’t optimise”. Let us know if that makes a difference.