Problem when flashing phusson gsi on Teracube 2e

Hi, I’m trying to flash the latest GSI (both ab and a) from phusson, and I’m having some issues.

I managed to unlock the bootloader just fine, but when I tried to do:
fastboot flash system gsi.img.xz

it says FAILED(remote: This partition doesn’t exist)

I’m not really sure why this error is happening, so extracted the img file from the img.xz, and the result is still the same.

I’m on Ubuntu, and I installed the platform-tools using the CLI.

Does anyone have an idea?

Yeah - had run into this earlier. Android 10 introduced dynamic partitions. Some info here -

Try the following:

  1. fastboot reboot fastboot
  2. fastboot flash system gsi.img

I’ve yet to try any GSIs, but they should work. It might be a signing issue like with the magisk modified boot.img. I’m going to give it a try tonight and see if I can figure it out. There’s no way back to stock image at the moment for 2e, so I’d be a bit careful :slight_smile:

1 Like

Hi Sharad,

After doing fastboot reboot fastboot,
it gives me: fastboot: usage: unknown reboot target fastboot

If I do fastboot --version, it gives me:
fastboot version: 1:8.1.0+r23-8
I don’t if this can help the troubleshooting?

Perhaps we need to disable Android Verified Boot before proceeding or some sort of special command?

HI @Sharad,

After a lot of trial and error, I understood my mistakes.

  • I was using an out of date version of Android Platform Tools (ADB & Fastboot). Linux users should not install it using the package manager
  • Since the Teracube 2e uses fastbootd, we have to do fastboot reboot fastboot like you mentionned, but because of mistake #1, I was unable to.
  • Once mistake #1 & mistake #2 has been figured out, we can flash the images as instructed, however I encountered a problem with the size of my partition being not big enough, but I found an issue on phusson’s gsi repo that should solve this problem.
  • After solving the previous problem, I didn’t encounter any problems while flashing the GSI (arm64, aonly). Unfortunately, both the latest version of phusson’s Android 11 GSI, and Android 10 GSI did not post, and it just kept booting into fastboot mode. Just like @Jake said, since there aren’t any ways to go back to stock image at the moment, I should have been more careful (but this is a risk that I’m willing to take)
  • I don’t know if there’s a way that I can extract some logs that can potentially help phusson bring GSI support for this phone (or maybe something just went wrong with me)

I did play around with the phone before messing it up, and to be honest, it’s a solid device that I can recommend to friends & families that just wants a simple phone. You guys did a great job!

1 Like

Out of curiosity, did you flash that blank vbmeta image? My issues that I outlined in this post I believe we’re linked to some signing requirement in vbmeta. You could try signing his GSIs using similar steps to my post, that could work! Let me know if you need more instructions or have any other questions.

Just wondering @Sharad, is there an ETA on SP Flash files for 2e? Would be super nice to not worry about that! :slight_smile:


Warning : Advanced users only. Be careful with using SP Flash software. If not used properly, it can wipe the entire disk including IMEI numbers.

Here you go - I have updated the SP Flash article with links to 2e factory files.


Amazing! Thank you very much Sharad!

Seems to be like other people on this chipset are also having this issue. I’m looking into this.

1 Like

Chiming in here to say I’ve successfully flashed phh’s latest Feb patch level AOSP 11 GSI (system-roar-arm64-ab-vanilla). It was pretty straightforward:

  1. Unlock bootloader
  2. Reboot into fastboot, and then again into fastbootd
  3. Flash system image - fastboot flash system image.img
  4. fastboot -w <-- I ran this three times (one extra for luck)
  5. Profit

I was concerned that I’d have vbmeta issues, but that didn’t cause any problem for me.

Otherwise things seem to work well with the device. UI navigation and effects don’t seem as fluid, so I wonder if there are GPU acceleration issues going on (or if it’s even using hardware rendering?). Fingerprint scanner works, camera works. I haven’t tested it on cellular yet but I’m not very concerned. Overall huge success!


No such luck… I spent a good hour configuring the system, playing around with it, and decided I no longer needed Root. I pressed the “Securize” option in settings which rebooted, and now it’s stuck at the initial boot screen (“Orange State” message with Powered by android at the bottom). Reflashing doesn’t seem to help either… It’s just stuck. Bummer.