Slow, buggy issues - anyone else or just me?

Having had my phone for approx 6mths now I’m beginning to regret the purchase.

I’m not a huge power user, so happy to have middle of the road phones but I also expect it to work better than my previous >2yr old Android from Huawei. I am frequently rebooting (cold and warm) due to the phone going in to ‘odd mode’. By this I mean, I could be messaging one of my children when suddenly after every key press [on the keyboard] the drag down top menu keeps appearing. Or the app in use will crash or just hang for a period of time.

Reboots work, of course they do it’s been a staple of the tech world for years to say ‘reboot’. But this is getting annoying now. My main use of the phone is:

  • As a phone… odd, but true.
  • for messaging my family
  • occasional social media use - mostly Twitter and FB (ugh)
  • as an emergency camera if I’m out and didn’t bring my big one with me
  • and once in a blue moon as the interface for my drone
  • lots of other apps used once in a blue moon - e.g. Waze (works fine so far), food apps, hotel booking apps, etc

In fact the drone use was the first time I’ve used it as got the phone March/April and been in lockdown since, and no chance to do so prior. The problem here is that as soon as the drone hit about 20metres directly above me, I lost the image. My older Huawei managed to maintain image connection to VLOS (and beyond if I’m truthful - so over 500m).

Is all this just me and the way my phone is setup, or am I looking at a complete reset, which I despise with a passion? Just makes me want to go and buy an iPhone.

EDIT: on latest (stable?) build.

Hey, could you please confirm you’re talking about the Teracube 2e, and if so, are you running the stock Android, or /e/ operating system? Thanks!

Yes and yes. Sorry for any confusion.

Hi @stubbyd - welcome to Teracube forums. The drop down menu coming down unexpectedly was a known bug and has been fixed in SW16. If going to SW16 is not an option, then you can install an alternate launcher as mentioned in the known bug link above.

Do you know how the drone is connecting to the phone? Is it through a cable from its controller or a local wifi / Bluetooth connection to the controller and/or to the drone?

1 Like

Thanks for the reply …

I’ll try the SW16 and see how I get on - thanks.

As to the drone, it is a physical connection to the drone handset via a small cable. And yes, I have tried a second cable with very similar results.

Since it is a wired connection, there is no wireless range issue here. Could you check if this is a Display time out issue (Settings > Display > Screen timeout) OR the app itself is getting closed/killed? Any other guesses of what could be happening?

Would it be possible for you to take a video of the 2e screen when this happens?

The app is very much still running as I get a “video signal lost - return to home” message popup. I did try cancelling that and fiddle around a bit. But I will try and get a video if I can persuade someone to come along with me :slight_smile:

It isn’t a screen timeout issue as that isn’t configured.

But of more importance right now - the update to SW16 failed. And I really don’t want to do a factory reset.

Can you check your Build number - Settings > About phone > Build. Also what country are you based in?

OK - so build is:Terracube_2e_EEA_01_selftest and I’m in the UK.

We are running behind on our EU and UK build. You have 2 options:

  1. You can take a backup and then install the US build using SP Flash (PC) and then upgrade to SW16.

  2. [Easier route] You can install alternative launchers as suggested here.

I’ll have to hang fire then as not wanting the hassle right now - too many other things going on - and I’m already using Lawnchair launcher but still get the dropdown issue.

That is surprising if the dropdown issue is happening on Lawnchair. Definitely curious for a video now. Whenever you can.

1 Like