T1, Android 10.0.2 - wi-fi calling not functioning correctly

Hello! I’ve encountered a problem after upgrading from Android 9 to Android 10. Wi-fi calling simply fails.

What I’ve got:
Teracube One, Android 10.0.2, T-Mobile U.S., one SIM installed

I’ve checked the appropriate settings for wi-fi calling and toggled a few just to see if it changed anything - no luck. Calling while connected to a cellular tower still functions correctly. Texting and other internet dependent activities (Duolingo, et cetera) also function correctly. I’ve tried it at home, and at a few other WANs in the area, but that did not help - when a cell tower was available, it worked, and when one wasn’t, it didn’t.

I’ve noted a similar set of reports for Teracube 2e here, but not seen it reported in the Teracube One forum.

Another bit that is interesting is that this occasionally happened with the stock Android 9 that shipped with the phone. However, it only occurred a few times a month, and a reboot of the phone once or twice would resolve it, so I didn’t figure it was worth mentioning. Now its consistent, and it definitely became consistent right after the upgrade to Android 10.

Any help you can provide would be appreciated. I can send a bug report log to the dev team if you need it. I’d have started with them first, but I wanted to put this in the forum in case any other Teracube One owners are encountering the same problem.

Could you take a video and/or a screen capture of wifi calling not working. In addition, dev logs will be helpful as well.

This could be similar to the Teracube 2e issue where Wifi calling does not work in airplane mode.



I checked aeroplane mode since I never use it. It cannot be toggled by the quick settings button, but it can be toggled on the actual settings page where it is located. Toggling it doesn’t change the problem reported here.

I’ve sent the bug report data along with screenshots to devs@myteracube.com, per your request.

1 Like