Wi-Fi Calling on Dropdown menu missing?

The Joyn app has nothing to do with Wifi calling. As I mentioned earlier, AT&T enforces no wifi calling policy on all BYOD phones. Hence we had to specifically configure it such that it is not shown for AT&T (it’ll not work even if its there).

A post was split to a new topic: Wifi calling not working on O2 SIM?

What? A fundamental component of any modern phone has been borked to cater to just one carrier in the world? Not to make too fine of a point, but screw AT&T. If I wanted to be locked into their terrible service, I would’ve signed up for them a long time ago. This literally costs me money. Now when I’m out of the country on business, instead of being able to connect to WiFi and make standard calls I have to pay to roam.

The camera issues are a nuisance; this is a basic operational failure. Completely unacceptable.

while i understand that there will be growing pains with a new company and products, we just invested in 2x 2e phones to support the mission, success, etc. of Teracube. and like others the use of Wi-Fi calling/txting is essential. what’s more is that it was working recently before the latest update. @Sharad if there is not a quick fix/update pending, can we at least go back to a previous version of the system software where Wi-Fi calling works, and if so how?

thanks.

1 Like

The behavior seems NOT unique to Terracube: On a Ulefone Armor X8 with Android 10, over Ting/T-Mobile, wifi calling does NOT work if in airplane mode, and wifi on. As with @waynedpj , I get the message: “you must exit Airplane mode to make a call”

Hi @Dake and others - I want to make sure everyone is on the same page here. Teracube 2e still supports Wifi calling on all carriers except AT&T.

If you put an AT&T SIM, then you will not see wifi calling because of AT&T’s requirements. There might be some other phones out there that do support wifi calling on AT&T but they may be AT&T branded phones (or big brands who have a special deal).

There is nothing we could do here for AT&T - its their certification, their rules. If we didn’t comply, they wouldn’t certify us for HD calling and which would have meant that Teracube 2e would just not work with AT&T and Cricket.

Unfortunately that doesn’t appear to be accurate. I’m on T-mobile and lost WiFi calling with the last update. It worked before SW16 and is gone now.

@Sharad like @Dake i am also on T-Mobile and Wi-Fi Calling is not working on SW16:

  • i can see the Wi-Fi Calling settings only when the phone is not in Airplane Mode
  • once the phone goes in Airplane Mode (which turns off Wi-Fi) and i turn Wi-Fi back on, the Wi-Fi Calling settings are gone and i cannot make calls over Wi-Fi

please let me know if you need any more information to help resolve this issue.

thanks.

Thanks for clarifying. Wifi calling is working in general. However, it’s not working in the special case of airplane mode (cellular turned off) and Wifi on.

We are looking into it. However, the actual fix might take some time. If this is a blocker for some folks, then please roll back to SW6.

Also curious as to what scenarios do folks use this mode (airplane mode with wifi on)? Roaming seems to be one. Where else is this useful?

i am sorry if i was not clear but as i tried to say from the beginning Wi-Fi calling is NOT working at all on our 2e with T-Mobile, whether in Airplane Mode or not. when not in Airplane Mode and with Wi-Fi enabled i can see and change the settings, but the Wi-Fi calling always just says “Call over mobile network”

and when clicking on “Wi-Fi Calling” there is a big blank space where i assume there should be options to prefer calling over mobile, Wi-Fi, etc.

also on other phones with this SIM, when Wi-Fi Calling is working we see the carrier name in the upper left corner with Airplane Mode on with Wi-Fi enabled, something we have never seen on this 2e thus far.

i did notice today that if i put the 2e in Airplane and quickly re-enable Wi-Fi i can catch the Wi-Fi Calling settings before they disappear, and actually select between calling over Wi-Fi or mobile

however as discussed earlier in this thread, if i try to make a call i receive a dialog saying that calls cannot be made because Airplane Mode is enabled, even though as you can see the settings say “Call over Wi-Fi”.

i hope this makes things clear for at least my situation.

thanks.

Hi @waynedpj - is this TMobile EU or TMobile US? And yes - that does seem something is not working right in there. The Wifi calling setting should have option in there to select the priority (over wifi or over cellular).

Can you try removing your Vodafone SIM card, reboot and check again. In the meantime, I’ll ask the Devs to see if they would like to get a bug report from you.

I’ll just throw in that my phone behaves the same as Wayne’s. It’s Tmobile USA and I do not have any additional sims installed.

And to answer your earlier question:

Also curious as to what scenarios do folks use this mode (airplane mode with wifi on)? Roaming seems to be one. Where else is this useful?

Roaming is the primary reason, specifically internationally. When I’m in a hotel overseas I will put my phone in airplane mode and turn on the WiFi. W/WiFi calling enabled, regular texts or calls will then still come through, but I can be confident I’m not using my more expensive international rates. The other place I used it is actually ON airplanes connected to the aircraft’s WiFi and for similar reasons (though in this case just to be connected at all).

@Dake and @waynedpj - could you share logs? I checked on my TMobile connection, Wifi calling has a setting that allows to select “call over LTE or call over Wifi”.

Sharad, that’s what my T2e shows (I’m on T-Mobile as well), even though the /e/OS currently does not support VoWiFi. Hopefully devs can get that sorted soon! :crossed_fingers:

I have those options, but even when I tell it to use Wi-Fi only, as soon as airplane mode turns on (with Wi-Fi on and connected), those options go away (as in no longer even shown) and it will no longer make calls.

Update:

Ok so this is weird. I got it to work. I think this is what I did…

I had to be on the settings>network and internet>mobile network.

Went to Wi-Fi calling. Turned it on and selected Wi-Fi only. Then I turned on airplane mode. The first time I did it the settings disappeared, but I did it a second time and it actually worked. The nuisance is, I had to reboot the phone to get it back to normal as initially, I turned airplane mode off, turned Wi-Fi calling off, and it still wouldn’t connect to cellular.

UPDATE 2: Ok yeah, I’ve managed to do it again, but it’s clear something doesn’t like it. Once you’ve “tricked” the phone into Wi-Fi calling only, you have to reboot to get it back to normal. Just putting the settings back will prevent it from connecting to the network.

I can’t really sit down and do a bunch of screen caps at the moment, maybe later tonight.

Super. weird

Got it. Yeah - wifi calling in airplane mode is just not working/enabled at this point. We will look into it in Android 11 (being worked on right now).

Hi @waynedpj

In your screenshot, I see one cellular icon as connected whereas the other cellular network has “x” (disconnected). Can you check if TMobile was connected at this time? Also - is this TMobile US network? I ask because I see Vodafone IT as well.

i apologize for the long delay! we were moving to Italia from the USA and now are only finally getting settled enough to start catching up.

good eye @Sharad: at the time that these screenshots were taken we were still in the USA and yes it was the T-Mobile USA network in SIM slot 1. while taking these screenshots i also had our Italian SIM card (it is an MVNO that uses the Vodafone network) in SIM slot 2 in preparation for our departure. however before the screenshots i tested this no Wi-Fi Calling problem extensively with only our T-Mobile SIM card in the phone, again in the USA.

as an additional data point: now that we are in Italia and using only our MVNO Vodafone SIM in this 2e, the Wi-Fi Calling options have disappeared altogether!?

thanks, w

ahoy @Sharad and apologies for the delayed reply. as i explained in my last post we were moving and only are now getting caught up. while the Wi-Fi Calling seems completely broken on the 2e with Android 10, i just send the logs as you requested, though again we are now in Italia using a different SIM card … and how the Wi-Fi Calling options are totally gone!

thanks for your help and patience, w

Hi @waynedpj - all issues will now be handled in the Android 11 build. Would it be possible for you to test drive the A11 Alpha builds?