Teracube 2e with Tmobile (ex-Sprint)

I am having similar issues. I was one of those sprint People. Sprint would not accept the IMEI of the T2e so I had to get a T mobile phone, active the SIM using that phone’s IMEI, And then transfer the sim to the T2e. the sim worked for a few minutes but when i stated transferring in contacts and setting up the phone it switched to emergency call mode. I put the SIM back into the T mobile phone and it works fine (have access to network phone call and data)

What am i supposed to do? Are there settings I’m missing?

Can you check if this is relevant?

Yes option 1 is what I had to do in order to get the t mobile sim. I have it in T2e now (after putting it back in the t mobile phone for 1/2 hour and letting it sit there and for now its working in the T2e. after i put the sim back, in maybe 2 hours later I did get one message about “sim 2 is not allowed” (where the t mobile sim is) and cleared it but the phone is still connected. Sprint will disappear (become T mobile fully) by the end of this month. I’m hoping to register the T2e via its IMEI formally with T mobile after that.

As a way of an update, the phone has been working with T mobile SIM but I’ve had to restarted at least once per day because the sim locks to emergency connection only.

That is strange. Does going to airplane mode and coming back fix that? Not sure if this is related to your connection being ex-Sprint?

I’ll Try it and post :slight_smile:

I set the phone to airplane mode after it lost service (emergency service only) for 2 minutes and it made no difference. I repented it for 1 hour and it worked. But the second time it went to emergency service and put on airplane mode, it did not reconnect to T mobile. I retested the phone and its reconnected. What is the cause of this? I cant be expected to continually keep an eye on the cell connection to ensure network access when using this phone.

There is a high chance that it is because of your connection being originally from Sprint. TMobile is one of our most well-supported networks. Here are a few things to try:

  1. Try resetting your network settings. Goto Settings > System > Advanced > Reset > Reset wifi, mobile & bluetooth.
  2. Could you check if another TMobile SIM works fine on your phone?
  3. Try your SIM in the 2nd SIM slot on the back of the phone.
  4. Check with TMo customer service about this - they may reset the connection from their end or do something else to fix it.
  5. Is your phone connecting to LTE and also showing the VoLTE icon when you drag down from the top? You might have to disable wifi to see these icons.
  6. If nothing else works, then do a factory reset.

so I did #1
The T mobile sim has always been in the second SIM slot . the first slot didn’t work.
i can’t use T mobile costumer service recuse I keep getting defaulted to sprint. Sprint is supposed to go away in a few days and I will try again then.
The LTE does appear on occasion next to the signal indicator triage but never when the WiFi indicator is next to ti (the cone looking thing). I have never seen the VoLTE next to the triangle nor as part of the menu with the gray and blue round icons. Ill give it a few more days since i just reset all the radios and and get back to you

Hi, so no luck
I keep getting a “SIM 2 not allowed” a couple of times a day and I keep getting disconnected from the network several times per day. The message and the disconnections are not always at the same time. Sometimes i can get reconnected to the network after going on Airplane mode and sometimes I have to restart. even restart a couple of times in a row. I’ve checked my account and I’m still logging in under sprint even though I have requested my account to be ported over to T-mobile. I was asked to be patient in this regard. Any Ideas?

Unfortunately - that non-ported SIM will probably continue to have issues. Is there a way for your to start fresh with TMobile?

I’ve been told i have to wait till the account ports over. thank you for your help.

You could go with an MVNO that runs T-Mobile, like Net10. I’ve been using one of Net10’s T-Mobile sims since January, and it’s been working fine.

Curiously, this thing you describe:

this exact thing happened to me when I was still using my Net10 ATT sim card from my last phone in my Teracube 2e. It was really annoying, but as soon as I registered the new Net10 T-Mobile sim card to my Teracube, I didn’t have that problem anymore.

I’m hoping that once the account is ported over to T mobile completely (they are taking their time doing this) that my problem will also go away