Teracube One: phone does not boot, recovery mode does not boot, help


I have a Teracube One phone that will not boot, either normally or into recovery mode. Does anyone have any advice for how to recover this phone or, at the very least, retrieve data from it? Any magic button combinations I haven’t tried? Any way to get the phone to act like a hard drive I can mount long enough to get my data off it? Any possible last ditch stuff like taking it apart?

Here’s what happened and what I’ve tried:
Today, the phone was running fine and then all of a sudden turned itself off (it was just sitting on a table). I held the power button. The Teracube logo came up briefly, but the phone immediately shut itself down again. I thought it might have a dead battery, but it shows the same behavior when plugged in and also after being left alone to charge.

I followed the procedure to boot to recovery mode, but the phone will not boot to recovery mode either. It simply does the same thing. I hold power + volume up, the phone shows the menu, I select recovery mode and press volume down. The Teracube logo displays briefly, but then the phone shuts off. I’ve tried this a dozen times at this point and it’s the same thing every time.

Right now, the only thing I seem able to do is boot to factory mode: holding power + volume DOWN for awhile (~10 seconds), the Teracube logo shows up and then the phone boots to a text-only screen with “Factory Mode” at the top. There are a number of options for testing the phone and erasing the eMMC as well as rebooting (rebooting from here doesn’t help).

Thank you!

P.S. The real pisser is that this phone is the one I received a bit over a year ago after the screen on my previous Teracube One was destroyed: Factory reset Teracube One with inoperable touchscreen (no display, no touch) . I was hoping it’d last a few years.

1 Like

Could you do a factory reset from the options you see? (Do not clear eMMC)

1 Like

Hi @Sharad , I don’t see factory reset as one of the options listed, unfortunately.

1 Like

In that case, you can install the factory OS using SP Flash.

1 Like

Thanks. Will I be able to recover any of my data from the phone or is it going to end up overwritten? There are a few files on the phone I’d like to be able to retrieve if at all possbile.

1 Like

This process will clear all user data, unless you had anything stored on a microSDXC card.

Do you know if you used one for say, photo or media storage?

Hi @Saijin_Naib , thanks for confirming. No, I do not have an SD card in the phone. Everything stored on it is in the default internal storage (eMMC?)

Is there any other solution anyone can think of? I’m fully prepared to take the phone apart and try to salvage the eMMC or whatever is used for internal storage, if it comes to that.

1 Like

There is a way but it is not guaranteed to preserve your data.

During SP Flash, uncheck the userdata partition before you plug the USB cable. This will flash all other partitions, leaving userdata intact. If this works, great. If not, you can do the complete flash.

1 Like

Reading data directly off an eMMC is not impossible, but is certainly not easy and requires very specific hardware and skills.

For instance, the eMMC, despite being a type of MMC (precursor to SD) is directly soldered to the mainboard using a BGA pinout. You’ll need a reflow oven or a controlled-temperature hot-air work tool to remove it.

Reading the chip will require a custom harness/pinout, or a reader for BGA eMMC cards.

Further complicating things is that Android, by default, will be encrypting the userdata partition with a key(s) in the mainboard’s TEE (what backs the fingerprint sensor and provides hardware security features).

I think Sharad’s method is the only real viable path forward.

Understood, thank you!

1 Like

OK, I followed the instructions for using SP Flash to install the factory OS. It all went smoothly; no bumps or errors, the progress bar ticked up as usual and SP Flash reported the flashing was completed successfully. I left “userdata” unticked, as suggested, but otherwise flashed everything.

However, the phone is behaving in the same way. When I try to boot it, the Teracube logo flashes briefly on the screen and then the phone shuts down again. I am not able to boot into recovery, either–the same thing happens.

At this point it appears there’s probably some incurable hardware problem with the phone?

1 Like

Potentially, though it might resolve with another flash while also including userdata, though it will wipe that partition, as you know.

Perhaps try that, and open a warranty request with support@myteracube.com if it’s still not resolved?

Sounds good, I think that’s what I’ll do then.

Thanks very much for all your help @Saijin_Naib and @Sharad, I appreciate it.