Turning OFF the small LED to the right hand side of the notch when phone is locked and unlocked

Let me preface by saying I absolutely love Teracube 2e.
Having said that, the small LED to the right hand side of the notch was so annoying when I was looking at my phone when its unlocked. I went to settings and changed the following two settings. I am not sure which one fixed it but now I don’t see a flashing LED when I am looking at the phone unlocked.

Notifications --> Blink Light (Turned OFF)

Custom restrictions --> Don’t blink light (Unchecked the box in)

The LED still blinks when the screen is OFF, which is less annoying. It may have been designed with good intentions though. Is there any way to turn this LED off when the phone is locked?

2 Likes

Yeah - the notification LED is something I personally like and “use” a lot. However you are right - it can vary with personal preferences.

Just a clarification for other users, the notification LED settings can be reached at Settings > Apps & notifications > Notifications > Advanced.

Adding this as a feature request. Seems doable on the face of it.

3 Likes

Agreed. Got very used to it on my webOS devices, and it was a pleasant surprise to find it in the Teracube_One.

More options are never bad, though!

1 Like

Thanks for being so responsive @Sharad.

Now I am intrigued on how one can use the notification LED a lot!
Where can I find more information on its usage?

Sorry I just meant that I use the blinking led to mean I have notifications. Saves me from picking phone needlessly when there is no notification. :slight_smile:

2 Likes

Different apps also trigger different color notifications. For instance, Facebook Messenger notifications are blue on my phone, and calls/texts are green. If I see blue, I know I can let it sit a while.

1 Like

2e has a single color notification led.

1 Like

Ahh, still useful. I guess I’m spoiled by my TeraCube_One

4 Likes

I got my 2e yesterday and it’s doing well but I’m puzzled by this blinking LED too. I haven’t been able to turn it off, ever. I turned all notifications off. I rebooted. I turned off every switch I could find. It still blinks.
And I’m wondering where a detailed user-guide for the 2e exists. I haven’t found one on this site yet. Where its it???

Hi, Dave,
The LED should definitely turn off if there are no notifications available at all - that is, if you pull down the tray and all you see are the toggle button and the text “No Notifications”. If there are any notifications there, the LED will blink slowly any time the screen is locked. Unfortunately, the option to disable the notification LED doesn’t seem to have an effect right now, so we’ll have to fix that in a future update.

If the phone is unlocked, the LED should not blink. If the phone is plugged in to charge, the LED should be lit permanently.

Does that match the behavior you’re seeing?

The current 2e Guide is available at:
Teracube 2e User Guide

It is a work in progress, so if anything is missing that you’d like to see, just let us know.

2 Likes

Is there anyway to disable this LED entirely, even while the phone is charging?

1 Like

The LED seems to be a useful feature but too bright. When implementing the LED feature, is it possible to dim it to 50% or 25% or even 10% of its current brightness?

2 Likes

Well, now the light never blinks, and I can’t get it to start again. It stopped blinking about the time yesterday when your reply posted. It turns on when the charger is plugged in. But that’s it. I’ve turned the switches off and on again, and restarted twice. But nothing works. It’s still off. I’ve got notifications on for 10 apps. I’ve got “blink light” turned on. What else am I supposed to do?

Well, never mind. I turned off and on the “blink light” and now it’s blinking. There must be some bug in the code somewhere, that makes it not work consistently.

So, it was blinking again so I turn off the “blink light” switch and restarted. It continued blinking. I looked to see what the notification was for and found one app. So I opened that app and cleared the notification. Now the light isn’t blinking. But the problem seems to be that the “blink light” switch doesn’t reliably turn off the blink.

And the “User-Guide”… Calling it a work in progress is generous. I don’t mind being involved in a new product. I’ve had many of my own products at this stage. Maybe you need to make the User-Guide a project that users can contribute to.

And I like the 2e so far, though I’ve not used the camera yet and my wife’s iPhone 12 has a camera that you’ll never be able to equal. If you can even get your camera close to the 12 you’ll have significant bragging rights.

I think the 2e is a vast improvement over the original.

However, I was only able to turn off the light by searching “blink,” I would find the two described settings after doing a search for it, they would appear paired away from every other setting before I would type the k in “blink.” But no amount of navigating through the preferences would I find those two settings appear with every other setting.

In the early morning, I would prefer a brightness setting, as kishoredvrs has wondered. A search on Google Play for modifying this feature seems to be vacant at this point.

But I have learned from the past to not have the phone charge the battery all the way to 100% (also a settings feature), so maybe I can remember to unplug it before I go to sleep, the light is pretty glaring when I wake back up. Even still, I have since ordered two batteries because I see this phone as an incredibly novel concept over the iPhone, I would want to keep this phone over any iPhone ever made, even as I am on Macs regularly… I have discovered so many Google Play apps to sweeten the deal, to keep me interested in Teracube.

Sorry for writing as much as I did in this reply, but I am very happy with the 2e. I cannot wait to learn what will the Teracube team will do for Generation Three. Well done, Teracube!

2 Likes

I’m interested in what you said about not charging the battery to 100%. I’m just wondering why one shouldn’t do that?

1 Like

See the AccuBattery app on the Google Play Store. It explains everything. :slightly_smiling_face:

1 Like

Very interesting. I’ve learned a new thing. Thanks.

2 Likes

Look under “Battery” and then “Battery Charging Limit” and “Charging limit value.” This was a very pleasant surprise for me because charging a battery to 100% or close to it incurs slow damage and shortens the battery’s life. Likewise discharging to 0% or close to it. Dell has a program for its newer laptops that stops charging at a settable level, and it works great. I’m counting on the same advantage for the 2e’s battery.

3 Likes