Unable to flash any custom ROMs

Hi all,

I just got my new Teracube 2e (2nd batch), and the first thing I wanted to do after unboxing was load a custom ROM onto it. I’ve done this for basically every phone I’ve had and never had any problems, but it seems this time I’ve been defeated!

Here’s everything I’ve done so far, in chronological order. I was always careful to use the 2nd batch instructions/files.

  1. Unlocked bootloader via the provided guide, enabled USB debugging, etc.

  2. Attempted to install IodeOS (iode-2.7-20221014-emerald). I started by flashing their recovery image with fastboot, which went smoothly.

  3. Continued to the Apply From ADB step from recovery. Here I ran into a problem. When I ran adb sideload, it terminated pretty much immediately with “adb: failed to read command: success”. The recovery was stuck in the checksum verification phase, and after about 15 minutes of nothing happening, I unplugged the phone from USB. Turns out something was happening, cause a bunch of error messages started printing. At this point I powered off the phone.

  4. I discovered my Android platform-tools were out of date, so I updated them.

  5. I again tried to install IodeOS over ADB, and this time the installation appeared to go smoothly with no problems.

  6. Upon booting the phone after installing, I was greeted by the dm-verity “your system is corrupt” message. If I hit power to bypass that, I’d see the Orange State message, then the phone would reboot and I’d see dm-verity again. It’d eventually kick me into recovery mode, without ever getting past the boot screen.

  7. Followed these instructions to flash the stock image onto my phone. It succeeded.

  8. Upon booting, I still got the dm-verity corruption message. But after bypassing it, the phone successfully booted to the stock OS. The bootloader appeared to still be unlocked.

  9. Attempted to install an earlier version of IodeOS. No luck; this was essentially a repeat of Steps 5 through 8 (i.e. didn’t work and I flashed stock image again).

  10. Tried only installing the IodeOS recovery image, and discovered that just doing this was enough to cause the bootlooping described in Step 6.

  11. Decided I’d try my luck with LineageOS, especially cause that’s done by flashing rather than sideloading. So I first flashed the stock image again, then followed these instructions.

  12. Upon boot, the dm-verity corruption message was gone. However, it still boot looped once then kicked me to recovery, with a message saying “Can’t load Android system. Your data may be corrupt.”

And that’s where I am now. Apologies for this long post, I’m just excited to try out my new Teracube and I’ve never had problems installing ROMs before, so I’m a bit baffled. Could it be that the debacle in Step 3 has somehow ruined things (and still allows the stock image to work but nothing else)?

Thanks in advance for any help you can provide. Despite these hiccups, I’m extremely grateful to finally have a phone where the manufacturers themselves support tinkering and DIY repair – can’t wait to try it out!

Hey, are you still on the Lineage recovery page that says “your data may be corrupt”? If so, please follow the instructions on the screen and run a factory reset. That should fix your issue.

ADB sideload on recovery (I think) doesn’t really return any output as such. It will first verify package signature (~50% of the entire process) and flash accordingly. For that, I request you to please wait for some time since the flashing process is quite slow, compared to the fastboot package.

Wow you’re right, the factory reset did the trick. Thanks a bunch! Didn’t think it’d be that simple :stuck_out_tongue:


Glad everything worked out!