Unable to receive messages with images on Mint Mobile

My Teracube 2e will accept text messages but if they include an image it just says Downloading… indefinitely.

I have done Clear Cache and Clear Storage without results. I’m even willing to delete all messages if that will fix it. What’s next?

Hi @teracuber - welcome to Teracube forums. This seems like a APN configuration issue. Could you share what carrier are you using?

Mint Mobile. It’s been working fine for many months. Just recent trouble sending or receiving images.

Huh. I’m guessing you have tried basic things like reboot, etc?

Could you goto Settings > Apps & notifications > All apps > Messages. Clear Storage and Cache. Retry.

If this does not work, it might be worth checking with Mint customer service to see if anything has changed at their end.

Other mint users, are your MMS working?

I’ll check with Mint.

Thanks.

1 Like

It’s working fine for me, but I’m using the T-Mobile US (fast.t-mobile.com) settings instead of what Mint suggests. I’m doing the same on another phone as well & it seems to be the best settings to get everything to work in my area.

2 Likes

Thanks @MarVellJones. Could you share your full APN settings as well please?

Corrections to my earlier post: the name is slightly different (almost always irrelevant) & an option on my Pixel 3a XL under Bearer, NR, is not available on my Teracube 2e. Other than that they’re the same and what my phones default to when I use Mint Mobile. I only seem to have problems when I switch them to the Mint Mobile suggested settings.

Name
T-Mobile US LTE

APN
fast.t-mobile.com

Proxy
Not set

Port
Not set

Username
Not set

Password
Not set

Server
Not set

MMSC
http://mms.msg.eng.t-mobile.com/mms/wapenc

MMS Proxy
Not set

MMS port
Not set

MCC
310

MNC
260

Authentication Type
Not set

APN type
default,mms,supl,rcs,xcap

APN protocol
IPv6

APN roaming protocol
IPv4

APN enable/disable (this option appears greyed out)
APN enabled

Bearer
HSPA, EVDO_B, eHRPD, LTE, HSPAP, GPRS, EDGE, UMTS, IS95A, IS95B, 1xRTT, EVDO_0, EVDO_A, HSDPA, HSUPA

MVNO type
GID

MVNO value
756D

Thanks a ton @MarVellJones . I’m guessing some of the later settings like Bearer, MVNO Type, MVNO value can be left as default?

@teracuber - could you try to switch APN settings and try again?

Possibly, but these settings are what came up by default on both my phones with Mint Mobile SIM cards. The Teracube 2e is just a slightly different name for some reason. I do agree that some of the settings seem unnecessary but they work so I left them alone.