Visual Voicemail in Phone app not working - T-Mobile

The visual voicemail piece of the native Phone app is not working, I have T-Mobile. I was previously using a Pixel XL before the Teracube and the visual voicemail worked just fine for me on T-Mobile. That being said after searching on Google before posting here, it appears that in the past there were a handful of people who had this issue. There are some described fixes involving installing and uninstalling the T-Mobile visual voicemail version of the app. This did not work for me.

The only thing I can think of is my Pixel XL was on Android 10, but I fell my visual voicemail was working before the Android 10 update was pushed to my Pixel XL late last year.

Here is my issue more descriptively:

  1. In the phone app I go to Settings > Visual Voicemail and turn it to on
  2. A small message pops up below the setting title “Activating voicemail”
  3. Wait a minute or so with no change to the activation status
  4. Back out of settings
  5. On the Voicemail tab of the Phone app a message at the top says
    “Visual voicemail isn’t working”
    “Call voicemail to finish setting it up”
  6. I call my voicemail and listen to a saved message all the way through and hang up
  7. No change in the message, repeat steps above with some results
  8. Leave it sit for hours hoping it’s activating in the background or something, try calling voicemail again as the message still suggests to do, no luck

Is anyone else having issues with the visual voicemail?

The one other thing I will note that I tried was going into the back-end app settings through the android settings > apps and making sure the app had permissions for all categories. This didn’t change anything, just wanted to note I already tried that.

I have T-Mobile and I am using Visual Voicemail successfully.

However, in the included Phone app I do not see a “Visual Voicemail” tab nor an option in Settings! My Phone app setting have Settings>“Voicemail” but then only subsections Notifications and Advanced (which has the carrier and manual VM number)

No idea why mine is different.

This is what my settings look like

@William_Vidrine - Could you share how you got it working? Might be helpful for others.

Mine is still currently no working if that’s what you are asking.

I just installed Visual Voicemail off of the Play store.
It gives me notifications, but I do not have integration in the Phone app.

As I said before, I do not have the same Settings>Voicemail options – just Notifications and Advanced Settings

Yeah I’m talking about the built in voicemail in the native phone app. The T-Mobile app is garbage from what I hear and there is no reason to install another app if the native Android app has the functionality.

and oddly, mine just doesn’t have it

I think it’s because you have the other app installed, I heard others saying that when I was reading about how to try and fix my issue. If you don’t have the voicemail toggle shown in my first screenshot set to on, the voicemail tab will not be shown. I don’t think you can toggle it on if you have the app installed but I don’t know that for sure.

I uninstalled it and it changed in Settings< Voicemail

Now the toggle just stalls saying 'Activating Voicemail"

Same problem as me. Do you get the “call voicemail to finish setting up” when you aren’t in settings?

no, but in notifications I get “Having difficulty retrieving voicemail”, and when I tap it and Visual VM opens, my messages sync and are listed.

I get the exact same error message (carrier is Ultra Mobile which resells T-Mobile).

But then I also got that exact same error message on Ultra Mobile from my previous phone (Nexus 6 on Lineage OS), so it’s likely not a Teracube issue. Or at least not SOLELY a Teracube issue.

Not working here either. Seems to be an incompatibility between Google phone app and T-Mobile voicemail (Our phone app is made by Google).

As mentioned in my original post this was working just fine on my Pixel XL (pretty old phone) which is all native Google, exact same phone app. So I agree this is the Google phone app, I have seen it work in the past.

Is there any way to try and trap some error messages in the background so we can get more clarity on where it’s failing to setup?

You can enable adb (USB debugging) from Developer tools on the phone and then run adb logcat from Windows. If you are new to adb - there are tons of tutorials online on how to do this.

I’m also having this issue. I followed about the same steps as above. I can access my voicemail by dialing 123 and I’ve already set up my voicemail box including the greeting, etc. But when I try to set up visual voicemail, I always get a message like, “We are experiencing some issues with activation. We will retry in a few minutes.”

Is the Teracube team aware of this issue?

You can also install the T-mobile version of the Visual Voicemail app. I have been using that successfully on my Teracube.