Wi-Fi Calling on Dropdown menu missing?

Hi @waynedpj - is this TMobile EU or TMobile US? And yes - that does seem something is not working right in there. The Wifi calling setting should have option in there to select the priority (over wifi or over cellular).

Can you try removing your Vodafone SIM card, reboot and check again. In the meantime, I’ll ask the Devs to see if they would like to get a bug report from you.

I’ll just throw in that my phone behaves the same as Wayne’s. It’s Tmobile USA and I do not have any additional sims installed.

And to answer your earlier question:

Also curious as to what scenarios do folks use this mode (airplane mode with wifi on)? Roaming seems to be one. Where else is this useful?

Roaming is the primary reason, specifically internationally. When I’m in a hotel overseas I will put my phone in airplane mode and turn on the WiFi. W/WiFi calling enabled, regular texts or calls will then still come through, but I can be confident I’m not using my more expensive international rates. The other place I used it is actually ON airplanes connected to the aircraft’s WiFi and for similar reasons (though in this case just to be connected at all).

@Dake and @waynedpj - could you share logs? I checked on my TMobile connection, Wifi calling has a setting that allows to select “call over LTE or call over Wifi”.

Sharad, that’s what my T2e shows (I’m on T-Mobile as well), even though the /e/OS currently does not support VoWiFi. Hopefully devs can get that sorted soon! :crossed_fingers:

I have those options, but even when I tell it to use Wi-Fi only, as soon as airplane mode turns on (with Wi-Fi on and connected), those options go away (as in no longer even shown) and it will no longer make calls.


Ok so this is weird. I got it to work. I think this is what I did…

I had to be on the settings>network and internet>mobile network.

Went to Wi-Fi calling. Turned it on and selected Wi-Fi only. Then I turned on airplane mode. The first time I did it the settings disappeared, but I did it a second time and it actually worked. The nuisance is, I had to reboot the phone to get it back to normal as initially, I turned airplane mode off, turned Wi-Fi calling off, and it still wouldn’t connect to cellular.

UPDATE 2: Ok yeah, I’ve managed to do it again, but it’s clear something doesn’t like it. Once you’ve “tricked” the phone into Wi-Fi calling only, you have to reboot to get it back to normal. Just putting the settings back will prevent it from connecting to the network.

I can’t really sit down and do a bunch of screen caps at the moment, maybe later tonight.

Super. weird

Got it. Yeah - wifi calling in airplane mode is just not working/enabled at this point. We will look into it in Android 11 (being worked on right now).

Hi @waynedpj

In your screenshot, I see one cellular icon as connected whereas the other cellular network has “x” (disconnected). Can you check if TMobile was connected at this time? Also - is this TMobile US network? I ask because I see Vodafone IT as well.

i apologize for the long delay! we were moving to Italia from the USA and now are only finally getting settled enough to start catching up.

good eye @Sharad: at the time that these screenshots were taken we were still in the USA and yes it was the T-Mobile USA network in SIM slot 1. while taking these screenshots i also had our Italian SIM card (it is an MVNO that uses the Vodafone network) in SIM slot 2 in preparation for our departure. however before the screenshots i tested this no Wi-Fi Calling problem extensively with only our T-Mobile SIM card in the phone, again in the USA.

as an additional data point: now that we are in Italia and using only our MVNO Vodafone SIM in this 2e, the Wi-Fi Calling options have disappeared altogether!?

thanks, w

ahoy @Sharad and apologies for the delayed reply. as i explained in my last post we were moving and only are now getting caught up. while the Wi-Fi Calling seems completely broken on the 2e with Android 10, i just send the logs as you requested, though again we are now in Italia using a different SIM card … and how the Wi-Fi Calling options are totally gone!

thanks for your help and patience, w

Hi @waynedpj - all issues will now be handled in the Android 11 build. Would it be possible for you to test drive the A11 Alpha builds?

sorry @Sharad for the delay, we were still on the road when this message arrived and it got missed in the shuffle.

as for testing the new builds, the 2e is our main connection to the world currently … so unless it is very simple to switch between the current and alpha build, with little chance of screwing up the existing stock 2e ROM, then unfortunately i cannot help out right now.

thanks, w