Wi-Fi calling turns itself off

Hi folks. Newish 2e user. Kicked AT&T ($90/mo.) to the curb, and went to Ting/T-Mobile ($30/mo). We have zero bars of nG (5, 4, 3, 2, any) at the house, so wifi calling is our only option.

Every time we come home, the 2e automatically connects to our wi-fi, but we have to manually remember to go Settings->Network->Mobile->Advanced->Wi-Fi Calling and turn it on. It’s a pain, and easy to forget.

Is there a way to make it turn on automatically? IFTT? An app?

Also, its not clear whether “Call over Wi-Fi” preference or “Call over mobile network” is better for our situation. Any suggestions?

I also noticed another thread in here where WiFiCalling was an option available in drop-down, but isn’t any more (due to ATT!).

Hi @Patrick_Larkin - the wifi calling option should stay on and should get you registered on wifi calling as soon as wifi is connected. If its not working, then its most likely a bug. I’ll get the team to look into it asap.

For situations where the cellular signal is really low, “Call over Wi-Fi” is better.

Wifi calling as a feature is still there for all carriers except AT&T. Only thing that got removed is a quick tile shortcut to enable/disable wifi calling (the ones you see when you drag from the top).

I just tested on T-Mobile with SW16. Wifi calling comes back on as soon as Wifi connects (as expected). Maybe something is happening with Ting.

Could you capture a screen recording and logs as follows:

  1. Enable Developer options.
  2. Use the screen recording app (AZscreenrecorder) to record the screen.
    2.1 Start recording
    2.2 Walk out so that wifi disconnects. Drag down from status bar to show connectivity icons.
    2.3 Walk back in so that wifi reconnects. Wait for few seconds and then again drag down to show connectivity icons.
  3. Share logs and the captured video.