[working now] No mobile data

I’ve had my teracube 2e for just over a month now. I’ve never got mobile data to work on it yet (which isn’t a huge issue for me but it would be nice to be able to get MMS messages). Not really sure where to start looking for the problem or fix. I’m on /e/OS 0.18-20210828132307 … I am considering trying regular android to see if it works there or not (is it worth trying this?). My carrier is Tello on the t-mobile network. Everything else that I’ve tried to use is working well.


Things I’ve tried so far:
enable roaming
change preferred network type to 3g
change preferred network type to 2g
turn off mobile data / turn it back on
turn off “automatically select network” – this brings up a “choose network” page which is blank.

And yes, I am on a 2gb data plan (plenty for my use case)

Any thoughts what to look at next? Is it more likely to be a hardware issue, or an os issue, or some kind of compatibility problem with my carrier?

Most likely the APN settings are not working. Could you please add a new APN with the following settings:

I think you may be on the right track, a problem with APN. Unfortunately, I get this screen:


I tried adding the info from the page you linked, but upon saving it, I get the same screen that the settings are not available for this user. ??

After some additional internet searching, I then tried rebooting the phone (didn’t work), shut it off, remove sim, turn it on, turn it back off, re-insert sim, turn it back on (didn’t work).

Finally came across a suggestion on this page Not able to edit APN Settings - OnePlus Community that said to leave MCC/MNC on their default values when adding a new access point name. So I tried that (MNC defaults to 240 for me), and that part seems to have worked now. I can now disconnect from wifi and still browse the web.

However, my MMS messages still don’t seem to be coming in properly (I get a download option, but it just spins and never completes). I did try rebooting the phone again after it took the APN setting, and sent a new test MMS from another phone.

Update: after looking through Tello Mobile | Frequently Asked Questions | Help Center I found under iOS settings, they list 2 different APNs, one specifically for MMS (“service”). I changed mine to that, and both mobile data and MMS are working now! Unfortunately my older messages are not retrievable (message expired or not available), but nothing terribly important was missed (that I know of).

Thanks for pointing me in the right direction!

1 Like

Glad that it’s working now. Your trail should be super helpful to other tello users as well. :+1: :heart_eyes: