[Advanced] Installing factory Android image w/ SP Flash

The driver bundle provided doesn’t include a digital signature (*.cat) file, so it can’t be installed on any modern version of Windows; all 64-bit versions of Windows require a digital signature for the driver bundle (which has been a real PITA for anyone that needs to make .inf files to describe hardware that works with existing signed .sys drivers). Windows 10 also doesn’t recognize the device - the tool doesn’t move or show any signs of life, and for a brief period, all I see is “MT65xx Preloader” as an unknown device in Device Manager.

Kinda getting super frustrated trying to do this super easy process :thinking: Has anyone tried this on a clean PC to see if it’s as easy as quoted, without any pre-existing development tools/drivers installed?

update: Here is a signed driver bundle: Download MediaTek Preloader USB VCOM Drivers (for MT65xx, MT67xx and MT68xx Chipest) and installation guide - TechReen - probably a good idea to replace that link with one that doesn’t ask someone to change their Windows configuration to allow unsigned drivers (very, very inadvisable practice!) and use a bodged driver like that. Just get a signed version :wink: which isn’t available automatically in Windows by default.

1 Like

Thanks - link updated to signed drivers.

1 Like

I was attempting to flash /e/ following the directions on their site . After a PM with @Gagan he thought that the 2e that was shipped to me possibly came with SW after SW6 causing my initial error in the link provided. I am now attempting to flash SW6 using a Linux machine and having issue with the “timing” outlined in steps 8-9 with a bootloop. I can’t get the tool to flash, it keeps returning the error in the screen shot below. I still have access to boot /recovery and /fastboot. When I boot recovery the message,

“E: Failed to bind mount /mnt/staging/emulated/media/0 to /storage/emulated: No such file or directory
E:emulated failed to bind mount /mnt/staging/emulated/media/0on /storage/emulated: No such file or directory”

Any direction to get the flash tool working to get me back to SW6 would be greatly appreciated. Thanks in advance.

did you run LineageOS-18.1 before?

1 Like

No, directly from the Vanilla ROM it shipped with. I believe the install directions on /e/'s site are for SW6 as previously discussed. I believe this is why the flash errors in my post on /e/'s forum were happening.

EDIT: However I did flash /e/'s recovery successfully from what I could see in the terminal and on phone log, while /e/'s ROM flash failed. After this I believe the stock ROM factory reset the partition it was on. I did also attempt to flash Lineage 18.1 but it failed, maybe this is why my current recovery is labelled as such (18.1)?

While I’d normally recommend people to use SPFT on Windows, on Linux you can either set udev rules for /dev/ttyACM* or just run SPFT as root (which is what I end up doing, honestly).
If running SPFT as root (or setting correct udev rules) does not fix the issue, please share SPFT logs (Help > Open Logs Folder).

Just to recap the flashing process, make sure the drop-down reads “Download only”. Hit the “Download” button in SPFT first, then connect your phone powered off or connect your phone and restart it. If SPFT has the right permissions (usually to /dev/ttyACM0 on Linux), it’ll start flashing right away.

2 Likes

Thank you for this. I will attempt to do this as root and if I am unsuccessful I have a Windows box I can try. Will report back.

1 Like

Yes, that is why you are seeing Lineage-18.1’s recovery.
You can flash any custom ROM once you’re on SW6. Again, I’m working on fixing builds on SW16+

1 Like

Was able to correct using the commands below after unziping the SPFT Linux tool (as outlined by @swap38 previously). My inexperience with Linux was the culprit all along. Thank you @Gagan and @AgentFabulous

chmod +x flash_tool
sudo bash flash_tool.sh

Now to see if I can get /e/ up and going with this SW6! If successful I will report this to their team to update the installation directions (current need to flash SW6, this will need updating after @Gagan finishes :point_down: )

:pray: thank you again.

SW6 was not the issue. When I attempt to wipe the data when in fastboot I receive the following error:

fastboot -w
wiping userdata…
Invalid logical-block-size 512: must be a power of 2 and at least 4096.
mke2fs 1.45.5 (07-Jan-2020)
/tmp/TemporaryFile-nKtgVK: Unimplemented ext2 library function while setting up superblock
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata

Also receiving this error if attempting to flash the system image. Are any of the newer 2e’s being shipped with different partition set ups that previous? I just received this device yesterday, 6/25/2021.

fastboot flash system system.img
target reported max download size of 134217728 bytes
sending sparse ‘system’ 1/14 (131068 KB)…
OKAY [ 4.068s]
writing ‘system’ 1/14…
FAILED (remote: This partition doesn’t exist)
finished. total time: 4.076s

I do now have TWRP sucessfully flashed and functioning.

EDIT: I have successfully installed iodeOS via a simple ADB sideload through TWRP. Hope I can get /e/ on here someday but I can’t figure it out as of now.

EDIT: Finally resolved my issue with help from aibd on /e/'s forms. It was an issue with me using the “System” Android tools and not the “Latest”. Purged the “System” and did commands ./from the “Latest” folder and fixed the issue. Thank you for the 2e, super excited for this project!

Congratulations, and I’m happy to know that you’ve successfully installed /e/ on your device! :smiley:

1 Like

I am running Debian 11.

When trying to run flash_tool.sh, I was getting an error message re: not finding libpng12-0.so.0 or similar.

symlink to current version did not work.

Tried to download and install the dpkg which was from Jessie. Had a multiarch-support dependency. Ugh.

Noticed there was a lib directory in the SP_Flash_Tool extracted directory. Opened the deb file with ark and extracted libpng12.so.0.50.0 to the SP_FlashTool’s lib directory and created a symbolic link for libpng12.so.0 to libpng12.so.0.50.0.

SP Flash then launched.

Maybe this can save someone else some pain and suffering.

2 Likes

Hey guys I run teracube one and have Mint 20 kernal 5.4.0-81-generic.

I have been trying to flash the teracube one to andriod nine and I only get this in the phone flash tool.

Any help would be greatly appreciated. I am out a phone now.


y

I’m assuming you don’t have access to a Windows 10 computer? Also - what version of SP Flash are you using and where did you get it from?

Hi egx470,
could you please explain the commands you have used to fix the issue. Sorry, I do not understand. Where are the “System” and “Latest” version ?
Could be usefull to describe the process for other Linux beginners :wink:
Many thanks
spray

I’m having the boot-looping issue when I try to install the factory image, but the instructions for that case seem unclear. ‘When its screen is dark’? The screen is always dark when the phone is off. Am I supposed to turn the phone on and then try to time connecting it after the ‘dm-verity corruption’ etc. message comes up and it starts turning the phone off again?

Hi @degraine - apologies for the delayed response. The trick for a boot loop is to keep the PC ready in download mode and insert the cable into the phone as soon as the phone’s display turns dark.

I have done all the steps correct, I have windows 10 and all files but its saying to select at least one ROM file and I have selected all files, Please help how can I fix this.

It seems your firmware files are missing (look at the empty Location column in your screenshot). Are you sure you unzipped the full firmware and are selecting the scatter file from that folder?

@robert Hi!
Could you please fix the link to the Teracube One factory SW?