[Advanced] Installing factory Android image w/ SP Flash

I’m having the boot-looping issue when I try to install the factory image, but the instructions for that case seem unclear. ‘When its screen is dark’? The screen is always dark when the phone is off. Am I supposed to turn the phone on and then try to time connecting it after the ‘dm-verity corruption’ etc. message comes up and it starts turning the phone off again?

Hi @degraine - apologies for the delayed response. The trick for a boot loop is to keep the PC ready in download mode and insert the cable into the phone as soon as the phone’s display turns dark.

I have done all the steps correct, I have windows 10 and all files but its saying to select at least one ROM file and I have selected all files, Please help how can I fix this.

It seems your firmware files are missing (look at the empty Location column in your screenshot). Are you sure you unzipped the full firmware and are selecting the scatter file from that folder?

@robert Hi!
Could you please fix the link to the Teracube One factory SW?

1 Like

Hi @kunicasport - thanks a ton for pointing that broken link :heart:. Fixed now.

1 Like

Thanks for this guide. Two things:

  1. The factory images linked seem to be somewhat dated (2020) for the Teracube 2e. Are there any updated images?
  2. Can the difference between the EU and the “rest of the world” image summarized briefly? (I suspect it to be either some privacy issue or competition issue as the EU has much better regulations regarding these two issues than the “rest of the word”)

6 posts were split to a new topic: T2e 2022 batch - how to restore to factory?

Worked for me, thank you!

1 Like


After some trouble with my phone I have flashed the stock ROM Teracube 2e 2022 following this how to and the process was successful. So my computer is able to detect the serial interface through the USB wire.

Now, I am facing to an issue where I am not able to reboot my device, the screen is black and nothing happens!

Have you some idea and advice for rebooting my device?

Thank you

Ok, I look good now. I am able to reboot to the stock ROM. I have another issue right now but I will add comment in another topic.

1 Like

After three months happily using /e/OS on my Teracube 2e (emerald), I started having severe network problems and decided to go back to factory Android using the How-to guide that links to this thread. SP Flash completed the process apparently successfully and the boot screen says “powered by Android” again, but all I can boot into is /e/ Recovery. Any ideas about what I did wrong and how to go about fixing it?

I’ve tried: flashing again, launching SP Flash as Administrator and flashing, factory resetting phone from Recovery.

As I recall, I installed /e/OS using ADB on Debian. I tried to install the factory image with SP Flash on Windows 10.


Hi @kbel - could you try this alternate process to install the factory OS?

1 Like

Thanks for highlighting that for me. I’ll try it out.
Edit: The alternate process appears to have worked! Thanks again.

Hi all,

As many people here, I installed /e/, used it for a while and then decided to go back to Android (unfortunately).

To install /e/ I had to unlock the bootloader. After installing back the default Android rom, there was not a step to lock the bootloader again. Can I do it or not?

Yes - you can lock the bootloader again. Follow the Unlock the Bootloader guide, just change the unlock command to fastboot flashing lock

Doesn’t work on ubuntu 22.04 LTS.

$ ./flash_tool.sh                                                                                                                                      
./flash_tool: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Trying to cheat lib versions results in symbol mismatch:

$ sudo ln -sf /usr/lib/x86_64-linux-gnu/libpng16.so.16.37.0 /usr/lib/x86_64-linux-gnu/libpng12.so.0
$ ./flash_tool.sh 
./flash_tool: /lib/x86_64-linux-gnu/libpng12.so.0: version `PNG12_0' not found (required by lib/libQtGui.so.4)

I really want it to work, but I have too little time to tinker with this. (Why does the tool require a GUI anyway? Where is the cmdline version with fewer ephemeral dependencies?) It looks like I’ll have to buy a cheap moto or similar as I need a phone and don’t really have a backup option at this point.

Mediatek has a bad habit of continuing with old packages for libpng.
The libpng12 library needs to be installed, from what I see Ubuntu bundles libpng16, and has deprecated libpng12
Fix libpng12-0 Missing In Ubuntu 18.04, 19.10, 20.04 Or 20.10 - Linux Uprising Blog
Maybe give this a try?

1 Like

Another option would be running the Windows version via WINE. I have had success with that in the past.

I wish this would be packaged up as a Flatpak to ease some of these problems…

This just saved my Teracube 2e’s hide. thank you! Now I can reinstall /e/ os using easy installer again! I got stuck in an Orange State bootloop. Scary stuff!