Advisory - [US] Issues related to AT&T / Cricket (or other ATT based MVNOs) - April 2022

Hi Sharad,

Presumably you had to deal with some high-level ATT techs to get your phones certified. Do you think you might get back in touch with them and see if they know what’s going on and when it might end? Downshifting to 3g (phone says 4: which is it? I thought LTE was 4) from LTE to use the phone as a, you know, phone, is getting sort of tedious. You’re a small player in a big bad phone world, but we civilians aren’t even walk-ons, won’t get any respect.



Hi Sharad,

Given that some number of your phones aren’t really working with ATT and its MVNOs, you should probably stop selling them as ‘ATT Certified’, as that amounts to false advertising.

Unless, that is, you plan on doing something about it, which doesn’t seem to be the case.



1 Like

Straight from ATT:

Given how much pushback and hoop-jumping ATT gave TeraCube for prior certifications, I’m sure they’re doing the same again. It should be resolved in due time, with no thanks to ATT it seems.

1 Like

Good find. And it says 'Last updated: May 13, 2022’ so they’re still claiming the 2e works whereas at least some 2es and apparently some other phones don’t actually really work, if set to LTE.

Before this started, my phone icon would switch automatically to ‘4g’ when making a call, and it stopped doing that, so I’m assuming it was an ATT tower telling the phone to switch.
When one downshifts the phone to call, the option offered is ‘3g’ but the icon says '4g.

If ‘4g’ really means ‘3g’, and ATT is shutting down their 3g net, it means pretty soon all the affected handsets won’t even really be ‘phones’ anymore. I sure wish TMO reached where I live…

So, after completely wiping my phone and losing everything from this year because the alleged Teracube ‘software team’ can’t be bothered to make TWRP work, so no backups, which I did trying to switch from Iodé to /e/ (never again!), in order to try to fix this ATT problem, ATT just turned off the 3g in my area, so no voice at all.
Got a T-Mobile sim (should have months ago) and voice over LTE works. It’s not our phones, it’s not Teracube, it’s ATT.
Tl;dr: ATT is evil and incompetent, the worst of the bad, and no one should ever use them


More info: this image is from the current BYOD compatibility list at a Cricket Wireless (meaning ATT) location. It appears to be upside down, but lists “Teracube 2e model TR20072EQ”, whereas my phone, which does not get VoLTE service from ATT (but does from T-Mobile), claims the " Model" is “Teracube 2e” and the “Serial number” is “202011T2E00 etc etc”.
This apparent mismatch might be why I stopped getting VoLTE from ATT (or maybe never got it) and had to switch to T-Mobile.
A staffer at the Cricket location put her own Cricket sim in my phone as a test, and sure enough, no VoLTE, meaning no voice at all now. So not sim, not acct, but a phone—ATT incompatibility.
So while Teracube claims the 2e is ATT compatible, at least some aren’t. More amateurishness.

1 Like

I’m also having this issue and sent an email to do testing for a new build that should fix this but haven’t heard anything back. Has anyone else contacted support via email?

@jbray - AT&T (and Cricket) have told us clearly that both our phones (including both versions) are compatible. The Model number is the same for both Serial numbers. The issue is at their end and is also affecting other phones.

In general, I have seen a number of posts from you disparaging Teracube. We are trying our best at something different than others. And yes, we have not figured out many things. However, we will continue to learn and keep moving forward.

If you have constructive feedback, please share - it is very helpful. But posts meant to demean the team or devalue what we are doing are not helpful. If you are not happy or the Teracube phone is not working for you, I’ll suggest you decide one way or another.


@faith - what phone and build are you running? And are you not getting 4G data or 4G calling?

1 Like

Hi Sharad,

I have the Teracube 2e. I’m not getting Volt LTE calling on my Red Pocket sim on the ATT network. I just added a sim on Monday in my second slot from Mint mobile and it works fine.

Faith R. Douglas

1 Like

Hi @faith - issue with Red Pocket on AT&T has been covered in this thread. I will let you read posts from other Teracube users - the issue is most likely on RedPocket/AT&T side. This is why I stick to our recommendation to move to TMobile or RedPocket+TMobile in your case.

1 Like

Hi Sharad,

I’ve wasted quite a few hours on the phone with useless scriptmonkeys trying to get to an actual Cricket/ATT tech. Been to Cricket stores at least three times, changed sims, etc. What have you done? If anything, you haven’t told us.

It’s clear this problem is affecting more than one or two users, and that it is a Teracube—ATT compatibility issue. If you are going to keep claiming your phones are ATT compatible, you should do so with the caveat that some aren’t, but no one has really tried (apparently) to figure out exactly which ones and why, and get it fixed, so caveat emptor and good luck. If you had, of course, I wouldn’t have bought one.

As it is, I was forced to finally switch to T-Mobile when ATT turned off their 3g here, but their coverage is much weaker than ATT where I am, so I’m pretty much screwed unless I want to get some locked-down un-rom-able nonremovable-battery ATT 5g phone, or somehow find a Teracube that actually works with ATT and use mine as a spare.

Maybe, come to think of it, since this problem is clearly WONTFIX, you should offer exchanges of effectively defective phones for ones that work as advertised.

Here’s an idea: maybe some phones come with different radios/modems. The About Phone doesn’t list a Baseband, just a Build: “RQ3A.211001.001 dev-keys” on my phone. Whatever it is, it means that the ATT net (or their LTE subcontractor if they have one) is for some reason not accepting these devices as VoLTE valid devices. Could be in radio hardware/firmware.


@Sharad I believe in the vision, that is why I bought one of your phones. However, asking us all to just switch carriers is not quite fair. If the problem is with AT&T, then I would hope that teracube would be pushing the issue with them more aggressively. I do not get the sense that teracube is doing that, and I don’t feel cared about as a costumer. I am happy to be patient if I know that teracube is taking the issue seriously and is keeping me in the loop as to how they are persuading AT&T to fix this. I genuinely feel teracube is just taking an ‘oh that’s too bad, but nothing we can go’ approach. If that is the case, then fair enough, but you should at least offer a buy back. Please understand that as a consumer, I need a phone that can at least make and receive calls and texts for my day to day life. I have family members who are frustrated with me because I often don’t receive important calls or texts until days later. I am not a hater at all, yet I agree with those who are saying that letting this problem continue equates to false advertising of AT&T compatibility.

Hi @loki_asguardian - I can feel your pain. We are a small fish in the pond of big 3 US carriers. We did deal with AT&T for our certification but that’s a standard engagement. Both AT&T and TMobile shutdown their 3G networks. However, TMobile had no issues while AT&T had tons of them (and based on other users’ reports - AT&T had issues on other brand phones as well). And this was beyond what we can do or could have envisioned.

Going ahead, we are removing AT&T as a supported carrier (it will be removed from the website before the next batch goes live).

If moving to a supported TMobile-based carrier is not an option for you, then I’ll suggest you can list your phone on the Marketplace where it seems to be a good demand for used Teracube 2e phones.

I am in the same boat with my new TeraCube. How do I check or change the APN please. I can 't find the procedure in this forum when I search for it.

Thank you

Hi TeracubeUser7,
Go to settings ->start typing access (top search field)choose [Access Point Names]scroll to the bottom-> Advanced->scroll to the bottom Access Point Name.
Once there see which radio button is filled in… not yours(theirs)? hit the 3 buttons top right and add New APN. You didn’t state which carrier you have, but the carriers web site (under support) or customer service should have it listed freely. Hope this helps
BTW, Sharad had this posted on this forum

Thank you Pat. I did try several different APN settings to no avail.

This worked on /e/ OS, I don’t know if it helps with stock OS, but worth trying.
Go to Settings > System > Advanced > Reset Options > Reset Wi-Fi, mobile & Bluetooth. Click Reset settings.
This made the phone work on AT&T.
Let me know if it works for you.

I agree, that is definitely the next step. It de-clutters everything and gives a fresh slate for you and a service tech to work on. It was my experience to have tech support, on the other end, have them send me a text/picture to verify.

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.