Iode OS + Red Pocket calls not working?

I suspect that I am being affected by the 3G shutdown on RedPocket.

Can anybody comment?

Teracube 2e (purchased June 2021)
iodeOS version 2.3 (January 27, 2022)

No Incoming or Outgoing Calls Possible
Data and Text Messages still work

Troubleshooting Attempted

  1. Rebooted phone
  2. Turned mobile data on and off
  3. Verified that VoLTE is enabled
  4. Upgraded from version 1.x iodeOS to version 2.3 iodeOS
  5. Called Redpocket, verified phone is on whitelist, data and text function, Access Point Name (APN) is present, SIM card is OK, etc.
  6. Redpocket had me turn the phone off, wait 10 minutes, then boot.

Still unable to make or receive phone calls.

Hi @Give_Me_Liberty - this is most likely due to some missing carrier configuration. Few things to check:

  1. If it is easy for you to go back to factory firmware, please install (T2e-2021) A10 from here and test again. (Just be careful to select the right firmware for your 2021 unit)
  2. Can you try the 2nd SIM slot in the back of the phone.
  3. Would you happen to have another SIM card from a different carrier? Preferably TMobile?
  4. Does your RedPocket SIM card work in another phone?
  5. Is your Red Pocket SIM card GSMT (based on TMobile) or GSMA (based on AT&T) ? might be a good data point.

@Sharad thank you for your quick response!

Phone is GSMA

I haven’t had time to test your other steps. Based on the update below, I believe that this is a carrier issue. See below.

The problem is now reversed. The phone can make phonecalls and use SMS, but no cellular data.

  • Spent 5 hours on chat support this morning with Red Pocket
  • Support had me check the VoLTE toggle, reset all network settings, reboot, and update the APN information. Also tried toggling the preferred network from LTE to 3G.
  • We reached the end of the troubleshooting chain and elevated.
  • Advanced technical support verified that the issue I am experiencing is the same issue that is affecting a significant number of Red Pocket customers and that I have been added to the list of affected customers.
  • I was told to expect a callback in 24 to 48 hours.

Let’s hope they get it going. I’ll also suggest to try their GSMT SIM card - it might make a difference.

After spending an hour and a half speaking with tech support, they had me update the APN and the phone’s capabilities reversed once again. I have data, but I cannot make or receive phonecalls.

I spent time experimenting with the APN “Name” and “APN” field, all other settings kept constant.

The “APN” field determines whether you have call functionality, or just data.

Armed with this new information, I decided to try to get in touch with Red Pocket Support once again…

Red Pocket Chat Support wait time is ~21 hours…

I think I might take advantage of the dual SIM functionality and order a GSMT SIM…

I persevered and waited on the chat.

Steps to Resolve the Issue:

  1. Reset your network settings by navigating to:
    Settings>System>Advanced>Reset Options>Reset Wi-Fi,mobile & BlueTooth
  2. Hit “Reset Settings” and follow the prompt.
  3. Navigate to:
    Settings>Network&Internet>Mobile Network>Access Point Names
  4. Now add the Red Pocket APN by hitting the “+” sign.

Name Red Pocket Mobile
Proxy Not set
Port Not set
Username Not set
Password Not set
Server Not set
MMS Proxy
MMS Port 80
MCC 310
MNC 410
Authentication Type None
APN Type Default,mms,supl
APN Protocol IPv4
Bearer Unspecified

Save the APN

  1. Confirm the APN you just added appears in the list of APNs, it should read

Red Pocket Mobile

  1. Select the Red Pocket Mobile APN by tapping the Radio Button next to it.

  2. Try testing your data and your calls.

Below is my configuration:

Outcome: Data and Calls
Signal Identifier LTE
Internet Speed 12 Mbps down / 5 Mbps up
Phone Settings
Mobile Data ON
Roaming OFF
Data warning and limit No limit set
Preferred Network Type LTE
Wi-Fi calling OFF
Carrier Video Calling ON
Automatically Select Network ON
Choose Network AT&T Greyed Out
Access Point Names Sub Heading
ATT Nextgenphone nxtgenphone Radio button NOT selected
ATT Phone, phone Radio button NOT selected
ATT WAP wap.cingular Radio button NOT selected
TracFone tfdata Radio button NOT selected
ATT IMS ims No Radio button
Red Pocket Mobile ERESELLER Radio Button Selected
APN Detail
Name Red Pocket Mobile
Proxy Not Set
Port Not Set
Username Not Set
Password Not Set
Server Not Set
MMS proxy
MMS port 80
MCC 310
MNC 410
Authentication Type None
APN Type Default,mms,supl
APN protocol IPv4
APN roaming protocol Not Set
APN enable/disable APN enabled Greyed Out
Bearer Unspecified
MVNO type None
MVNO value Not Set Greyed Out

That did the trick! I think that full network reset was the secret to making this work. (That was the only thing in your steps I had not tried.)

I now have VoLTE with the ability to place and receive calls. Thank you!

1 Like

My “Solution” appears to only be a temporary solution. I experienced the same symptoms that @Robert_Lowe is experiencing here link. After resetting the network I have full capabilities, after time passes I lose calling capability…

I found a way to live with the situation temporarily. After resetting the networking settings and restoring the Red Pocket APN, there is an additional APN present called NXTGENPHONE, switching to that provides calling capabilities but no data. I have been leaving my phone set to NXTGENPHONE so that I can make and receive calls. When I need data I switch to the Red Pocket APN. So far I have never NOT been able to use NXTGENPHONE for calling.

I have also experienced the temporary nature of the network reset fix. I have reset it several times. Unfortunately, I do not see the “NXTGENPHONE” APN. I have to reset each time, which is a bit tedious with all the re-pairing and re-entry of wifi information.

Sadly, I think the only permanent fix will be to replace my phone with a more current and well-supported device. The Teracube 2e only maintained its calling capabilities for 8 months, which means its been the shortest lived android phone I have ever owned.

As a Red Pocket customer, I’m exceedingly disappointed with their handling of this situation.

I too am given temporary fixes, all around the APN settings. As entering a new APN profile doesn’t save it anywhere, it is an incredible hassle having to switch between a phone that can access data and hotspot functionality but cannot make or receive calls, to having to lose the APN settings in switching to the “Default” AT&T APN just to have a phone that can receive and make calls but cannot be used as a hotspot. I pay for the service and expect it to work as intended.

It appears AT&T shutting down their 3G transmissions has also affected other MVNOs as well, as I’m seeing this problem in numerous forums on the net.

Can you confirm if this is the right APN that worked for you too? If everyone confirms the working APN, we can see if we can fix the APN in our build and give an updated build that has the correct APN in it.

The APN you have linked to was provided to me as well by Red Pocket customer service but it only allowed call making and receiving for a day or two at best. The hotspot functionality however required even more APN adjustment by the cr rep as seen hi-lighted below:

APN Detail

Name: Red Pocket Mobile
Proxy: Not Set
Port: Not Set
Username: Not Set
Password: Not Set
Server: Not Set
MMS proxy:
MMS port: 80
MCC: 310
MNC: 410
Authentication Type: None
APN Type: default,mms,supl,hipri,fota,cbs,wap,xcap,rcs,bip,vsim
APN protocol: IPv4
APN roaming protocol: Not Set
APN enable/disable|APN enabled: Greyed Out|
Bearer: Unspecified
MVNO value: 310410x

But if I want to make phonecalls, I have to tap the “default APN” setting, which enters the ATTNextgen APN and knocks out the above settings completely.

Omg - this is indeed a mess. Have you thought of switching to a TMobile-based MVNO? Maybe RedPocket-TMo?