[Alpha] Android 12 for Teracube One

This is our first Alpha build of Android 12 for Teracube One. It needs to be installed using the SP Flash software (see known issues below).

Advanced users only: This is an Alpha stage build. You could lose data. If something goes wrong, you will have to install Android 10 builds using SP Flash.

SP Flash Build (link) (Note: SPFlash software is here)

Current known issues:

  • Uncertified build (similar to a custom ROM)
  • Needs to be installed via SP Flash. Can not be updated from old Android 10 builds.
  • OTA updates do not work. So any future builds will need to be installed via SP Flash as well.
  • Vowifi does not work (VoLTE works)

What works

  • Wifi, Bluetooth, VoLTE all work
  • Google play store and almost all apps (except Netflix)

The Dev team is working on fixing OTA and other issues. We will keep releasing periodic builds.

2 Likes

Can I just say whaaaaaaaaaat.

Will get this on a test unit and benchmarked here by the weekend :smiley:

Thanks to you and the team!

2 Likes

This is the first time I’m positively surprised, although my expectation is quite low at this point.
The update runs well after flashing through MTK SP Flash. It has the December patch so pretty recent. The kernel update to 4.14 means it opens the possibility to GSI ROMs to at least Android 13. Good job on the update.
A few bugs I noticed, although it doesn’t bother me much because this isn’t my primary device:

  • Opening the camera produces a sound of something physically clashing. Not a good sound, like the iPhone 14 Pro camera module. Not from the speakers, but from the camera module. Only happens once each time when any app uses the rear camera. I speculate it is focus unit resetting to its default position when camera is accessed, but the firmware is not calibrated so it tried to go too far. I’ve disabled the Camera app because I don’t really need to use it anyway.
  • The proximity sensor doesn’t work (uncalibrated?). If I go into a call the screen shuts itself off even when I’m not blocking the screen (it should stay on). If I measure it in an app like AIDA, it reports to be flicking between covered and uncovered constantly.
  • APN setting doesn’t save if I changed MNC from 240 to 260 following my carrier (TextNow)'s instruction. Data seems to work just fine without the setting but it was just confusing to see it fail silently.
  • Wi-Fi sometimes turns itself off but I haven’t isolated how to reproduce it.
1 Like


Android 9: BL# 8015974
Android 10.1.0: My Device
Android 12: BL8055447
PerformanceTest Compare (2).pdf (481.8 KB)

Do you have a screen protector on your T1?

Regarding the proximity sensor - can you try cleaning it up, removing it or moving it slightly to the right (facing the phone)

1 Like

this is going to get a huge boost the next update hopefully :wink:

2 Likes

Do we know if anyone rooted this yet?

1 Like

Oh, that’s wonderful news!

Any areas in specific you are able to comment upon?

1 Like

Good news. Over the course of a few days the proximity sensor fixed itself. I don’t know what happened but it is no longer flickering. I have the original plastic screen protector which doesn’t cover the sensor.

The other good news is I observed some camera sensor turning sound on other devices as well, like the iPhone SE. So this isn’t unique to the Galaxy A53 and it is probably fine for the hardware to do that.

Other than Wi-Fi stability issues, I don’t think there is any other issue. Pretty solid overall.

2 Likes

Can we get better instructions for flashing.
Also:

1- Do I need to Flash Android 10 , then Android 12?
2- Can I flash everything except for userdata.img?

You don’t have to flash Android 10 first. Just use SP Flash and flash this build. And sorry - you can’t keep the old userdata.img. However, you can restore your old backup after the install.

1 Like

Restoring my old data including my apps data?

Any way to take a backup of userdata.img off my phone, now that it’s rooted?

Back to the flashing, after I hit download and all the items turn green, I plug in my phone (while it’s off, and nothing happens). I already installed the signed in driver as well.

Any idea why is it failing!?

1 Like

Is it giving you any error messages?

1 Like

No error message.
It just sits there doing nothing.

1 Like

Have you tried to force the phone on and off while connected to see if you can catch the SPFlash mode that way?

1 Like

Yup, I did, and nothing worked.
This phone had PixelExperience, I tried from the recovery menu, no bueno.

1 Like

Does it go into fastboot properly at all still?

1 Like

The phone is not detected at all.

1 Like

You’ve verified that the port, cable, and device all function properly?

Can it boot into pixel experience still, or is it bricked?

1 Like