AT&T Tracfone calls stopped working

I have a Teracube 2e that has stopped making or receiving calls. SMS and data work fine.
My network is AT&T (USA), via Tracfone as an MVNO.
The problem arose on March 17, 2022, apparently after 3G services were discontinued.
From searches on the AT&T forum it looks like the problem is that AT&T has custom standards for VoLTE that my phone is not using. AT&T lists Teracube 2e as an allowed device.

I am running /e/ that was installed by eFoundation in August, 2021

I can get voice over 3G, but sms does not work right. Or I can get sms and data over LTE but no voice.

I have followed the steps suggested for similar problems on other networks in these threads, but they aren’t helping. (I have not made a firmware change or been able to test a TMobile sim card though).

I’ve got a similar post on the /e/ forum, but no luck there yet. Would switching to Lineage be likely to help?

Hi @gpg - it most likely needs an updated APN for Tracfone (AT&T). Can you check if any of the Android settings mentioned here work - Tracfone APN Settings - BestMVNO . I’m guessing adding an APN in /e/ should be similar to regular Android phones.

Sharad, Thank you for the suggestions.

Unfortunately, neither of those APNs worked. I also tried APNs with AT&T addresses in the MMSC and MMS Proxy fields.

The APNs that you pointed me to both had MVNO type as unspecified. My setup automatically populated that field with GID, and if I was not able to save the APN with MVNO field set to “none”. I don’t know if that is important.

I don’t believe that I can get TMobile service where I live, but I will try tonight to enable a TMobile Tracfone SIM.

1 Like

I had the same problem with RedPocket on the GSMA (AT&T) network. The solution in this post: Iode OS + Red Pocket calls not working fixed it for me. You’ll want to replace the APN information with the correct info for TracFone, but resetting all network settings will likely fix your problem.

Be ready though! This fix is temporary. You’ll be doing this every 3-4 days if your experience is similar to mine. Each time you do it, you will have to re-pair all of your bluetooth devices and re-enter wifi information. I’ve found I have to be vigilant and proactive or else I start missing calls. If the VoLTE logo disappears, so does your ability to make and receive calls!

Robert–I tried your route and was unsuccessful.

But that’s good (and frustrating) to know that even if something like this does work I’ll have to keep updating the APN.

Not sure if this is limited to /e/ and/or Iode. I wish we could get feedback from users running Teracube OS (factory build).


I should have said in my original post that if I set 3G as the preferred network that I can make calls. SMS is not always reliable though. So I guess the 3G equipment is still working (for now), but that something changed in the way that the network gets chosen. I have a suspicion that all my calls since I got the phone have been on 3G.

I am having the same problem, after resetting the network the full capabilities are restored. Time passes and I lose calling capabilities. @Sharad If it is happening on both /e/ and iodeOS, it is probably happening on the factory images and I suspect it is a carrier problem…

I found a way to live with the situation temporarily. After resetting the networking settings and restoring the Red Pocket APN, there is an additional APN present called NXTGENPHONE, switching to that provides calling capabilities but no data. I have been leaving my phone set to NXTGENPHONE so that I can make and receive calls. When I need data I switch to the Red Pocket APN. So far I have never NOT been able to use NXTGENPHONE for calling.

1 Like

It seems these MVNOs will take time to figure out AT&T’s changes. In the meantime, we will recommend TMobile based SIMs (RedPocket GSMT, Tracfone on TMo, Mint mobile, etc)

1 Like

We have poor TMobile service where I live, but I’ll see if I can get it to work. I’ll report back if it does. Thanks for the help.

Did you ever get this figured out? I had a Samsung Galaxy S9 running /e/ using Straight Talk. First I ordered a Verizon SIM. They said I needed AT&T. So I ordered a AT&T SIM and it worked. Then they shut off the service because neither my SIM nor my device supported VoLTE. So I ordered a new AT&T SIM that never worked. So I bought the Teracube 2e and tried to set up my new AT&T SIM. They said I needed a Verizon SIM. I just happened to have a Verizon SIM. Then they once again said I needed a AT&T SIM. So I have that set up. I changed the APN settings to their recommended settings and everything. I still cannot make or receive calls. They finally just said my device is not supported.

I was thinking of just heading down to a Cricket store this weekend. The pain of it is, when I did set up my new phone with the Verizon SIM and tried to make a call, I got a voice message from Verizon saying that the SIM belonged to my old phone (I tried to set it up there before my new phone came). So that leads me to believe it worked?

I have never talked to two Straight Talk reps who say the same thing. This is frustrating.

Straight Talk has T-Mobile based SIMS and they are now telling me that the phone isn’t compatible with their service. This is after talking to 3 or 4 reps who said it is. I’m not sure what to believe but I’m looking forward to getting this figured out. I was thinking of hitting a Cricket store over the weekend to see what they have to say.

I haven’t gotten everything working yet.

I put a T-mobile Tracfone sim in the phone, and it works, but it’s actually roaming on ATT where I live. And it only works on 3G. I may be in a place this weekend with T-mobile service and I can see if it works using VoLTE.

I hear that /e/ is working on an OS update, so I’m hoping that I’ll be able to use ATT VoLTE soonish.

My 2e never worked at all on Verizon.

Sorry I’m not more helpful.