Autofocus is complete 💩 - blurry photos unless tediusly taken

I don’t need a beautiful studio-grade camera. I just need a functional one that takes photos of mostly technical pictures of activities when communicating with people at work, or sharing stuff with friends. While it’s definitely nice to have life-like color balance and incredible resolution, I can live without those.

What I can’t live without, though, is functional autofocus.

The camera on the 2e seems to habitually take blurry photos, unless I spend time and attention repeatedly tapping on a specific area, getting it to re-focus on a subject in the obvious middle of the frame. If I just whip out the camera and shoot at something I’m pointing at, it’s focused out in la-la land.

Most of the photos I take are of subjects an arm’s length away - that is, close-up, but not macro.

It’s incredibly frustrating, and building on my death-by-a-thousand-papercuts that’s killing my vibe with the Teracube 2e as my daily driver. Hopefully there’s some fix that could come via software in the near future, or another camera app that’ll more intelligently autofocus by default, instead of brainlessly snapping a photo with focus out in la-la land?

Optimally, the camera would aggressively attempt autofocus, repeatedly if it detects AF failure, before snapping a photo. That is: I click open the camera with the power button double-click, snap the shutter, and it’ll focus… fail… focus… fail… focus… lock on, and only then would it shutter-click. I’d be happy holding it steady, waiting for it to take an intelligent picture.

It seems like whenever the AF makes a full focus sweep (visibly blurring, then sharpening), it works. But it only does that sweep very rarely - like a camera driver bug or something.

1 Like

let me back this up with a couple example photos. I just waved around and took a few random shots from typical distances, with more or less typical lighting.

This is the result:

what is this. It should be pretty obvious where and how to focus here, but nope, no attempt was made. (An attempt was made shortly AFTER this photo was taken - an attempt it made automatically which itself is quite frustrating - but not before snapping the photo!)

i don’t know why i even bothered blurring the details on this beCAUSE YOU CANT EVEN READ IT :joy::sob: This was actually the frustrating situation that left me making this post in the first place

if I absolutely have to get a photo, as I did here, I’ll open the camera, tap tap tap tap tap on the subject, then quickly hit the shutter before autofocus automatically tries doing another focus sweep (despite having locked it in a moment earlier) and failing to lock, blurring the photo.

see my Google Photos gallery snippet? I took that printer control panel shot first while it was blurry, then immediately after taking it, it autofocused and got good focus. The photo it stored on the first shot was in-focus, but on the screen at the time it was blurry - that’s why I took a second one. So the focus even changes while the capture is in progress - meaning I can’t rely on the viewfinder actually being accurate - because it just autofocuses whenever the heck it wants, but never when or where I need it to. (I would be OK with this autofocus-on-capture if it actually worked, and if it repeatedly re-tried autofocus until it got a good one, and gave a UI cue to indicate that this was happening - and to be able to bypass/disable it, e.g. if I’ve focused on a specific point.)

Could you try OpenCamera app?

1 Like

I’ll give it a try when I get my phone back to daily use, hopefully Wednesday! My 2e is kinda tethered to USB at my home at the moment, providing whole-home internet during an … unexpected outage. Hopefully replacement gear will arrive tomorrow. tl;dr: I can’t tell for sure, yet, but I appreciate the suggestion and I’ll give it an honest go once I’m back to normal! :slight_smile:

So, the focus takes FOR FREAKING EVER, and anything using the flash comes up blue. This is true also for the opencamera app I tried from the referrals of other community members.
This is a fatal flaw for me. I take detailed photos to pass along requently, and between the focus issues and the blue color, I am extremely frustrated and await a real response that resolves these clearly common issues.
Thank you

1 Like

+1 for the “flash photos come out blue” issue. Color balance is a serious issue, and one that seems like it can easily be fixed with software tweaks.

I’m on my first day back with the phone, and after switching Open Camera to the default camera app, it’s actually made my quick-snap photo taking go smoothly. It seems to focus properly, and though the quality of the camera is still pretty “meh”, it’s no longer absolutely unusable with bad focus.

I have, however, had an issue last night with the T-Mobile Home Internet app, for specific example, not being able to focus on the QR code of the label. The app’s QR scanner just completely never even tried focusing at all, so the code was always blurry and it couldn’t scan. Blame there falls halfway between the device (the camera driver) and the app (no ability to tell the app to “tap-focus on this area”, or just to even attempt autofocus at all). A super frustrating experience, but got past it.

We are looking into the blue flash issue. Will update once there is something.

1 Like

I’ve had the same autofocus frustration that FalconFour complained about. I just installed the OpenCamera you suggested and at first glance the AF seems to function more predictably. Is Teracube going to update our code any time soon?

My other camera question is about camera resolution. My 2e compares very poorly to the iPhone 12, yet the 2e has 13MP and the iPhone12 has 12MP. Is this because of motion? AF? Sensor quality? I do know that when I took indoor, daytime pictures of my son raising our grandson up in the air the motion was terrible! Everyone in my family, 6 of us, plus friends and in-laws, all have iPhone 11s and 12s, except me. My camera is the brunt of jokes. And one son tells me to delete my low-quality pictures when I post something. And when I compare their pictures and mine, taken side-by-side, I can see poorer detail in the 2e pictures. I doubt OpenCamera will solve this problem. Is Teracube thinking about moving to a higher quality, more expensive sensor in the future?

1 Like

It’s about the quality of sensor, not number of pixels – this is why megapixels stopped mattering a long time ago. Having a ton of pixels means nothing if they’re garbage sensors serving each pixel. Hard to explain why, without showing tons of examples and getting into how light sensing works… but long story short: it’s a cheap sensor. The rear cameras on the 2e are the front cameras on other phones. But remember, it’s also a $200 phone.

I recognize that I bought a cheap phone, so that’s what I live with. I’m OK with the quality of this camera, 'til Teracube comes up with their higher-end version (not a “3e”, but dropping the “e” for economy). Remember: a single iPhone now costs 5x Teracube 2e’s. There’s a massive difference in price between the two. I imagine a bit of it has to do with gaining the experience to make a phone worthy of the higher price tag, and that’ll come soon.


Yes, I wish they’d chosen a sensor with fewer pixels, but larger for low-light, and higher quality.
Of course, Apple pays more for their sensor. But Apple also marks up their phone more. To me, one of the many advantages of Teracube is that their markup is lower.
I don’t know what the manufacturing costs of the sensors are, so I’m guessing. If I’d been given a choice of the cheap sensor or a higher-quality sensor for $40 more, I’d gladly spend the $40. Any idea what Sony gets for their 12MP sensor?

I’m getting so good god blessed tired of this phone’s awful camera and this autofocus problem…

I of course have only been using OpenCamera since it seemed to be better at its job than the stock camera. However, I consistently find, now, that it doesn’t perform autofocus at all when tapped - it only performs exposure adjustment on a blurry photo.

I spent about 30 seconds here struggling with the camera trying to take the following photo:

Behold: it is f*cking blurry. Despite how many times I tapped, tapped, tapped the screen (it did not perform a single focus sweep despite how many times I tried)… I point the camera away, point it back (it did not perform a focus sweep…), or when I closed and reopened the camera (it STILL did not perform a focus sweep).

This is not a failure of the autofocus algorithm to do its job - it’s a failure of the ability for software to trigger the autofocus to be performed in the first place. There seems to be no reliable way to TELL it to “focus on this, at this exact moment, now”. Tapping a spot only performs exposure adjustment on a spot, but it doesn’t focus.

This is so incredibly frustrating, it has basically trained me to stop even thinking of taking photos with my phone. To get that back, I have to buy a new phone. :frowning:

1 Like

I feel your pain. On my last phone I could tap on the screen and it would auto focus on that area. With this new phone, 2e, tapping changes the brightness/saturation levels instead which is really annoying. I have to wait until it decides to focus before I can take a picture, which takes a long time between shots.

1 Like

I also have stopped taking photos because of this reason.

I also have this issue. Recently, I bought a Teracube 2e

Somehow my Teracube 2e can autofocus after tapping, well it is not fast but at least usable. People here say that Open Camera is better, but I somehow cannot differentiate the result between Open Camera and Default Camera app.

@FalconFour @Trizzle (and others) - could you help us by providing a video (screen capture using AZScreenRecorder or a separate camera/phone… Few things to keep in mind:

  1. Tapping the screen does force the camera to try focussing. You might get green circle as a confirmation of focus competition or red circle for focus issues.

  2. We are specifically looking for scenarios where tapping and forcing the auto-focus still leads to blurry viewfinder and/or blurry pictures.

I’ll give this a go. Somewhat ashamed to admit, but I switched to an iPhone 8 Plus (refurbished :slight_smile: ) recently for my daily driver, partly due to this.

I would encourage others to take a video as well. Simply grab the app, have it start recording, then reproduce the issue with the camera not autofocusing-on-tap, then stop recording and post it (I use Google Photos - easy to share from there after it auto-uploads).

Very cool to see some dev interest in fixing this!


All right, here we go! LOTS of fun here in this capture. (I hope it entertains a few devs at least :wink: )

In this, I can easily reproduce both ends of it - working, and not working. Like always (and is my complaint), it seems totally random. It’ll get stuck in focus-lock, reporting random success (green frame)/failure (red frame) during periods when it’s not performing any focusing at all. I wonder if it’s stuck trying to “fine focus” and failing to do so, but not falling back to a coarse focus sweep instead. I seem to knock it out of its focus-lock almost literally, by pointing at some distant focus point then back to the subject. That often either gets it into, or out of, focus-lock.

Now, if I can just get my turntable to be a little less jerky with its speed adjustments… maybe I can get it to play smoothly again :thinking::crazy_face: (most of it is code I wrote 10 years ago, so… yeah no i had no idea what PID was. Maybe time to tune that!)

1 Like

Thanks a ton @FalconFour . That video seems to catch both scenarios. Have passed it on. Lets see what we come back with (will take some time though).

1 Like

Quick question - did you have SW6 (original firmware) or SW16 installed on your phone when you took that video?