Battery drain after recent update

After the last update my battery life has been cut in half or less. I can watch my charge drop by 2% in ten minutes of handling email, by 5% in 15 minutes of FB. It drops about 1% for every minute of YouTube. My battery is only a couple months old and this started immediately after the last update.

Is there a fix?


Sorry for the trouble.

Can you please provide us with more details about the device/device model, and the OS version?

Does the Battery information panel show anything with elevated usage?

It’s a TeraCube 2e. The battery app says everything is normal, but my battery life went to crud after the update pushed by TeraCube earlier this week.


My wife and I are both experiencing this as well right after performing the OTA update to 11. We both have SN2020 devices. Nothing shows out of the ordinary, but the device no longer gets a full day out of a charge. See attached screenshot. This really should be 6AM, not PM! :slightly_smiling_face:


Can you confirm whether or not your serial begins with 20xx (is a 2020/Zirconia 2e)?

Yes, it is 202011T2*******

1 Like

Yes, 202011T********

1 Like

I am also experiencing battery issues ever since getting the recent update. (In addition to losing the teracube launcher, as mentioned in this topic:

As for the battery issues, ever since the update my battery has also been draining very quickly. In addition, it sometimes won’t charge, even with chargers that have always worked before and continue to work just fine on other devices. I plug it in, and absolutely nothing happens: it doesn’t show that it is plugged in, and the battery level continues to deplete.

I decided to try and “reset” the battery by letting it run all the way to zero and then plugging it in. When I did, then it finally started charging again on the charger that wasn’t working for it before. So maybe letting the battery run out helped the issue somehow? Either way, it seems that the update was responsible for the issue in the first place, because I never had any problems with it until right after the update.


Thanks for confirming, @Lastbat .

I’ve upstreamed this and we’re going to investigate it.

1 Like

The development team have not come across anything specific to the 2020 models and the latest patch to Android 11, so a backup/factory reset is recommended to rule out a cache or other migration issue that might lead to elevated battery consumption.

I tried this and not sure if others have yet or not but I have not noticed any changes in behavior (the battery drain is still significantly worse than with Android 10).

1 Like

Thank you for confirming.

I’m not sure what would cause this behavior in this instance, unfortunately.

Back-flashing to 10 is an option, and might be best for affected devices at this time.

How do I go back to 10?

1 Like

I did an app reset as recommended, but noticed no change. I haven’t wanted to do a factory reset because it’s such a PITA.

1 Like

You would flash using SPFlash, but you will fully wipe the device, so a backup of user data is recommended.

Another option would be to wait until we ship Android 12 here shortly and test using that instead of doing a downgrade to (very likely) just upgrade again.

1 Like

I’m with Android 12 on Teracube One and experiencing fast battery draining as well.

Where did you source your Android 12 image from?

Straight from Teracube!

If this is the older Alpha that needed a fresh install via SPFlash, can you please try a factory reset or a reflash?

I am not hearing that battery drain was noted for this build on the One, and I didn’t run across it in my testing, either.

It was flashed by the Teracube team