Having some frustrating issues- How can I fix them?

My phone has begun displaying some weird hardware and performance issues. Random little ones have been stacking up for months. Every time I get used to one, it seems like a new one pops up that I have to learn to deal with. Almost all of these issues have lasted through updates and completely fresh installs of the software.

The issues:

  • As of android 11, for some reason, facebook messenger message searches are broken. I can perform the search, but only a tiny section of each chat loads. I reverted to android 10 for a bit recently while trying to install magisk, and that problem wasn’t present! When I first installed 11 again, facebook’s chat heads were active (rather than system bubbles), and the problem didn’t occur then, either. It immediately started again when the phone caught up and activated system bubbles. I don’t know if this is an issue in android 11 or the phone itself.
  • Sometimes, when opening or in the middle of using apps that host videos (e.g. tiktok), my display will first freeze, and then start flashing rapidly. The app itself is what flashes on and off, and I can see my wallpaper behind it as it flashes. Sometimes I can manage to restart the phone to stop it, but most of the time I have to pull the battery out to get it to turn off. This happens maybe once or twice a week.
  • I get dialogs constantly that the app I’m using isn’t responding, despite it working fine. I can dismiss these and keep using the app every time. Very rarely will an app actually crash.
  • Very recently, within the last week or two, my phone has begun randomly restarting itself in my pocket. I listen to a podcast on my phone while I’m at work, and have for months now, and only within this last little bit has it started to randomly restart while I do that. It also restarts randomly while charging, and oddly enough while not plugged in on my nightstand or other side of my bed at night.
  • Sometimes, when I turn my screen off and back on, it won’t respond to my touch to let me unlock it. I have to set it down and wait a bit, and then try again. It takes at most a minute, but this is still annoying.

I’m definitely not considering switching phones, because I need the repairability of this one, but this is driving me up the wall.

1 Like

Based on your attempt at running Magisk, is your phone rooted? Are you running apps in the background that require root access?

My best suggestion is a full wipe/restore to the stock ROM (or whatever ROM you’re using) without root & see if everything works properly. If you’ve already done full testing on this & still experience the same issues, you might need to do a tedious full wipe/restore as new (no installing from backups). Then install ONE app at a time, test & see if everything works, keep going until you replicate the problems.

One slightly easier alternative is to go through each app you’re using & search for incompatibilities or known conflicts with other apps.

I’m hoping someone else has an easier way for you, but that’s the extent of my suggestions.

1 Like

The only things that I think could be caused by root are the random restarting and lock screen being unresponsive, because those only startwd after I rooted.

However, I’ve had the phone rooted for nearly 2 months now, and these problems started only recently.

I’ll need to take a close look at all my apps when I have the time, as far as those 2 issues go. The rest, I’m not sure what do to…

Uh I’ve had the same issues and my phone isn’t rooted.

All of them, or just the rebooting and freezing?

Just about all of them

I wonder if some of these issues might be caused by the digitizer thinking a part of the screen is being pressed, perhaps intermittently? If you’re handy, maybe try disconnecting & reconnecting the ribbon cable as per step 2 here: Screen Replacement (Old process - Archived)

1 Like

Most of these have stopped happening at random. The unresponsiveness and random restarts thankfully sorted themselves out, and a messenger update fixed the search bug. I don’t use tiktok anymore, so I don’t know if the flashing bug is still a thing. The dialogs still pop up regularly, though.

1 Like

Hi I’m getting the same issues with random reboots and dialogue pop ups from certain apps. I’ve not rooted my phone - anytime out there who can help? I’m seriously considering changing phone now!


Hi @Benjamin_Brace - welcome to Teracube forums. Could you provide your Build version (Settings > About phone > Build).

Also - please do a soft reset. If that doesn’t fix it, then please do a full factory reset.


Hello there,

I’ll do the soft reset as you recommend and report back.

My the build number is Teracube_2e_A11_EEA_03



1 Like

I am also having the same issues and already tried the soft reset and fabric reset to no avail. I am just wondering if any of you guys were able to fix the issue - as in, is there any hope that Teracube will work?

I am not tech savvy and definitely do not want to become one to use a cellphone (as in, I have no idea what rooting a cellphone is and I have to fight back really angry tears to do the soft reset and fabric reset), so I am wondering if I should replace it or get a refund. My doubt is: will I have it replaced and find the same issues all over again or is there hope and I can have a decent functioning enviromental-friendly cellphone? Currently I am not happy with the purchase, but I am not sure if my issues were just me just being unlucky (I know issues can happen) or if they are recurrent ones.



I have good and bad news.

The bad news is that I know of no way you can actively fix these issues yourself.

The good news is that the issues resolved themselves over time as I kept using the phone. Rooting is not what fixed it, so you don’t have to worry about that.

I managed to use the phone daily amid those issues, so if you’re willing to wait it out, I’d give it a shot. If you can’t, I would definitely return the teracube and get a different device.



Sorry for the trouble.

Can you please confirm a few bits of information about your phone?

  1. Serial Number begins with what numbers (2x)?
  2. What software version are you on?

It is possible you are missing a platform firmware update that might resolve these issues for you.

1 Like