[Beta 2] Android 13 for Teracube 2e

We have certified builds out now. Zirconia and Emerald.

Archive

** Warning **

  1. Please backup your data before proceeding.
  2. Not for the faint-hearted. This is Beta software. If something goes wrong, you might lose your data and might have to re-flash factory Android (instructions at the bottom of this post).
  3. Read the notes before you install.

And we have reached 2nd Beta—many bug fixes, including Wifi calling and auto brightness.

What works

  1. Android 13 + Aug 2023 security update
  2. VoLTE, Vowifi, wifi, and Bluetooth have all been tested
  3. Upgrade from Android 10, 11, 12.1, 13-Beta1 have been tested in the lab
  4. Stable and even more smoother

Known issues/changes - do read before proceeding

  1. The build is not certified.
  2. Live Wallpapers not functioning.

Steps

  1. Download the upgrade zip file directly on the phone (or transfer the zip to the phone).
  1. Goto Settings > System > Updater (or Teracube Updater)
  2. Click top-right 3 dots > Local update
  3. Tap “Internal storage” and browse to Downloads or wherever you transferred/downloaded the update zip file.
    Note 1 : If Internal storage does not show anything, then reboot the phone.
    Note 2 : Do not download the update to SD card.
  4. Select the file and continue the update process.
    Note: If the Updater closes or crashes, then try again.
  5. Upgrade process will take a while.
  6. Reboot the phone after the updater says “Update installed”.

Let us know how it went and post your questions/feedback here. Please keep the comments related to this update itself.

If you experience any errors/issues, you can flash the original factory firmware using the automated installer or SP Flash.

3 Likes

Hi everyone,
good to have a new beta. Unfortunately my zirconia doesn’t show a “teracube updater” anymore. And the “updater” crashes after importing the local file (beta 2). I am running beta 1.
Any help is appreciated. :slightly_smiling_face:
Christoph

1 Like

Does the retry of the import do the same thing? Sometimes the local import fails and needs to be retried.

1 Like

A soft reset fixed the error. Beta 2 successfully installed.
The retry sometimes showed the message that the import failed.
However, I am happy now. The phone seems to work as it should.
Best wishes,
Christoph

3 Likes

FM radio stopped working after ca. 40 minutes. Since then it crashes while plugging in the wire / antenna. Restart the phone didn’t help.
It isn’t a big issue, I just enjoyed having the FM radio back again.
Best wishes,
Christoph

1 Like

Could you confirm whether your phone goes to the Android updating screen (black background with a circle) and stops in the middle?

1 Like

I just tested the upgrade from Zirconia 11.0.4 myself - it worked fine. Your recovery or something else may be corrupted. I’ll suggest to backup your data and do the following:

  1. Install Beta 2 with SP Flash using the Zirconia Beta 2 sp flash build

Or

  1. Install the factory A10 software using this automated installer.
  2. Setup A10 with your google backup.
  3. Then upgrade to A13-Beta 2 directly from A10.
2 Likes

Do you guys have an estimated timeline for the release of the certified build? Like: We’re definetly going to have a 3rd beta as release candidate in september and after that certification process will take another 2 months. So exited to bring all the family phones up to date… :innocent:

3 Likes

The certification process is on its way. I hesitate to give a timeline since there could be unknown roadblocks. If everything goes well - then the build could be certified in a 3-month timeframe.

6 Likes

Beta 2 for Zirconia updated well on my device. Thank you.

2 Likes

so with this not being certified what is not currently working? and do we still need to install the updater fix now or can we just install the beta? the updater fix will not install for me says error parsing and i have tried everything. will not install. so im hoping we dont still need to use it

1 Like

You need the updater fix only if you are currently on [Zirconia+Android12.1]. Otherwise, download the corresponding update file and follow the OTA instructions.

Everything works on this build - VoLTE, Vowifi, Bluetooth, wifi, etc. Build seems faster and smoother than all old Android versions :slight_smile:.

2 Likes

As seems to happen with my phone, updating Zirconia from 11.0.4 to 13.0.1 using the standard updater led to a system data corrupt, factory reset. Did the retry 5 times before giving in.
Going through initial setup now. Will see if I leave it on 13.0.1 or return to 11.0.4 to wait for certification after some playing when it all gets sorted out.

1 Like

Hi Sharad.

I have Beta 1 13 running and have been attempting to install the 2nd without much luck. Initially, every time I selected the new image zip file, I would see the “importing local update” msg and then the “Local Update has been imported” msg. As soon as I clicked on Install the app would crash. I tried multiple times and did such things as restart the phone, re-download the update, flush the updater app cache & flush the data cache. I believe what got me past the updater crash issue was when I looked at the app Package Version and rolled it back. Strangely I believe I saw I had version 12 and it rolled back to 13 - if that makes any sense. Regardless I was then able to move on in the install process. I got the “Preliminary Update Preparation” msg, then the “Teracube - Local Update - Aug 17, 2023 Install” msg then I got this confusing msg that listed the Beta 1 install with the new date:

Apply update
You are about to upgrade to Teracube 13.0.0+e80d34a.zirconia.user - Aug 17, 2023.
If you press OK, the device will restart itself in recovery mode to install the update.
Note: This feature requires a compatible Recovery or updates will need to be installed manually.
CANCEL OK

When I clicked on OK, I was taken back to the Preliminary Update Preparation msg and couldn’t get out of the loop formed by the steps and msgs described above.

I tried the same series of restarts, cache flushes and so on without any luck.

What would you recommend?
Mark

1 Like

Are you in a position to SPFlash back to stock Android 11 and try again?

For now, I’ve returned to 11.0.4 as there were enough apps that required certification to encourage patience.

If someone on Beta 2 is able to run YASNAC and post the fail, that’d be appreciated. I expect we fail both Basic and the CTS Profile with Hardware Attestation, but forgot to check before reverting and it’s been almost two days trying to get all my apps back to their prior states. If we only fail CTS and Basic is fine, that’d be a nifty result.

1 Like

No need to rush, I only wanted to confirm my guess. Many thanks for the info @Sharad

3 Likes

Hi, it doesn’t work for me.
I have an 2020 modell with 11.0.4 and uses the All Other Zirkonia download.
Only got a message “update failed” after the reboot.

1 Like

Hi @Martin_Re - could you do the following:

  1. Enable Developer options.
  2. Do the upgrade process again.
  3. After the phone reboots, take logs and share with us.
2 Likes