Phone automatically shuts off

First day with my Teracube, and twice already, I’ve gone to use my phone and it’s turned off. Once I get it turned back on, the battery is fine, it just seems to turn off/crash periodically.

What gives?

Huh - we have not come across this happening. I’ll suggest to continue monitoring this for now. If it persists - then we will get some logs collected. Not sure but it could be due to the main SW bug that we are tracking here.

I’ve had my phone randomly reboot itself twice now myself with the S1_06 firmware. The phone was just sitting on my desk and then I saw the screen go blank, then the start-up Teracube splash screen when it was starting back up.

This could be caused by a messed up cache or a mis-behaving app. Could you clear your cache using these steps and let us know if that takes care of these reboots.

Sharad, I got a Teracube for my dad (in India) and so obviously he’s a very basic user. He told me most people who have tried calling him after he switched get a “phone switched off” message and so he swapped the SIM back to his old phone. I have the phone for the past 4 days and it has shut down 5 times in the interim, couple of times even when connected to the charger. I have installed the big SW bug update and did the wipe cache partition you suggested above but no luck, consistently shuts down even after. Hope you can fix this as this has made the phone unusable. Thanks

@subru - can you confirm if you have SW6 update installed? You can check your Build number at Settings > System > About > Build.

Thanks Sharad for the prompt response. I edited my comment to call out that I do have the Teracube_S1_06 build but you replied even faster:).

And have you tried a factory reset to see if a fresh start makes a difference?

I just did a factory reset. I’ll report back in a day or so to see if the phantom shut down has gone away.Thanks

1 Like

So I didn’t have any issues like this with my first Teracube but after receiving a replacement because of water damage on my original, my phone is now restarting randomly a couple of times of day. Most of the times it’s when it is not being used. I will hear my phone clicking because it is at the encryption lock screen asking for my pattern so the phone can boot up.

I cleared the partition cache yesterday but now this morning I came back to my phone in the encryption unlock screen waiting for my pattern. The only thing different about this phone and my last is that I was a beta tester and installed the software update manually. With the new phone it prompted me to do the update through some wizard that downloaded it and installed in.

Thoughts on whether that could be resulting in this issue? Was there anything different about the software update delivered through the link on the forum and what was pushed to me on the new phone?

I might just give downloading the software update from the wiki link and installing it manually a shot to see if it works.

Could it be due an unstable app? Here are 2 things you can try:

  1. Boot into safe mode (using the below steps) and use the phone for some time to see if the issue reproduces.

How to invoke Safe mode

  1. Press and hold your device’s Power button.
  2. On your screen, touch and hold Power off Power. Tap OK .
  3. After you see “Safe mode” at the bottom of your screen, wait to see if the problem goes away.
  4. More details at this google support link.
  1. Do a backup & reset. While setting up the phone do not install all apps right away. First check if the phone is stable and then add your apps (possibly 1 by 1).

Well it’s not happening but 1 - 2 times a day so I would need to be in Safe mode for probably 48 hours to validate it doesn’t crash and not just coincidence. Not sure what other features might be disabled during safe mode which might make my phone more unusable than is feasible. Also, I did a backup and restore from my Teracube image that didn’t have any issues before so I wouldn’t suspect that it would be an app not working well now that was working fine before but ya never know I guess (no new apps installed since restoring from backup). Additionally because it only happens 1 to 2 times a day your suggestion of installing apps 1 at a time is not realistic, I can’t wait to install all the apps I rely on from day to day for 30+ days installing 1 - 2 a day.

Any answer to my question on differences in the software update downloaded from the wiki vs what was pushed?

They are both using the same zip. Can you check your Build number to make sure you have SW6?

Build number

That is the correct build number.

Hi. I’ve had my Teracube for a couple of months now and I’m getting frustrated with the phone randomly shooting itself off. It is completely random and does it whenever it wants. It sounds like I’m not the only one and that the suggestions aren’t working. My build is showing as Teracube_S1_06. I needed to know how to fix this or how to get a refund please. Thank you!

Could you please try the suggested steps in this post. If you have already tried them, did safe mode work better than the regular mode?

In addition, clearing cache can also help.