Settings app keeps freezing

Very frequently, I’m unable to access my settings menu due to it freezing. when going to the settings through a shortcut or through the notification drop down (pull the notification bar down, and selecting the gear), the screen will go black, but it will remain that way.
I have not found a consistent way to access the settings application when this occurs. tapping the screen repeatedly will eventually lead to the Android prompt asking whether I would like to wait for the app to respond or to kill the application. Killing the application doesn’t always resolve the issue.
I have also tried to kill the application by selecting the recent applications list and killing the settings application. This also does not resolve the issue.
The only way i can access the settings when this occurs is by repeatedly doing both methods of killing the setting menu until it eventually works.

Is this a known issue?
Is there a way to resolve this?
I’ve not done any manual OS updates.

Hi @habahnow - can you tell us which Build are you running? Its at Settings > About phone > Build.

My build number is: Teracube_2d_A11_05

Try the following:

  1. Goto Settings > Apps & notifications > See all apps > Search for “Settings” > Storage & cache > Clear Storage.
  2. If above does not help, then try a soft reset.
  3. If nothing else, then do a backup and factory reset.
1 Like

Thanks Sharad. I’ll try these things then and indicate in this thread if they resolve my issues or not.

Strange, I followed your steps @Sharad for clearing my settings’ storage and cache, and a short while after that, I ran into the settings freeze (and thought it perhaps your suggestion didn’t work). But since then, I have not experienced the issue. Normally I would run into this issue at least 1 a week or more. It seems that did resolve it. Thanks again!

1 Like