[SW16] Verified update for Teracube 2e is ready for all users

Seems like a potentially corrupted update file. Could you delete the old fine and re-download it.

Hello yes I did try that and no success sorry same error

Checking with Devs - will get back soon.

phone works fine just will not upgrade thanks

update next day, had to do a factory reset and was able to install ver 16 everything good thanks
so i believe the error was my fault as i did download the ver 16 zip file then opened and closed it instead of having the phone app open and install the new version.
one other thing I wasnt able to use sp to reimage phone, so good thing the reset worked

Updated from SW6 with only two minor issues that were easy to fix.

  1. AT&T Sim with sim card lock (pin) enabled was stuck on emergency calls only. Fixed by going to Settings > Security > Advanced > SIM card lock > disable lock and restarted phone. Back to normal and was able to re-enable the sim card lock.
  2. KISS (third party home app) would still open with the home button, but the other two buttons would open Quickstep. Went to Settings > Apps > Default apps > Home app, it was blank so I picked KISS. Had to restart phone for it properly apply.

3 posts were split to a new topic: Bell Canada issue with SW16

The process of downloading the zip file to update the security to May 2021 was quite easy due to the explicit instructions provided by Sharad. Thank you Sharad and keep up the good work.

1 Like

Does the update also fix the notification light issue?

The update doesn’t seem to be working for me. Do we need to extract the zip? When I follow these instructions and select the update file from the “local update” menu, it loads for a while and then nothing happens and it says “no new updates found.” However, it displays my software as version 06, not 16.

Keep the zip intact (don’t open it). Sometimes the display might time out and then the updater app fails. So you can increase your display timeout under Settings > Display and try again.

netflix no longer will update in google play on this version says its not compatible with this device. i know it is though since on another phone with android 10 it updates just fine. so what do we do to fix this. same for a few other apps. im getting them basically thinking the phone is rooted now but it is not.

Does your phone still say that it’s certified in the Play Store?

Is your bootloader unlocked - that’s another reason for Safety net failing.

Please install this app (link) and run the test to check if your Safety net is passing. Also check bootloader status (boot screen will show Orange state text if unlocked).

Interesting, would like to know more on this issue.
Could you attempt to install the update again, have it fail this way, and then once you’re back in Android, in Developer Options, just tap Bug report.
This may take a few minutes. Once it is done, it will generate a notification to share the report. You can either DM it to us through forums, or mail it to devs@myteracube.com.

no it is as it comes from teracube just with the beta 15 then the 16 updates installed nothing more. and its only netflix. but i know netflix can be updated on other android 10 devices so it makes no sense.

downloaded and passed no issues at all. netflix is the only one she cant update. tells her its not compatible with this device. she uses netflix all the time so she is pretty upset about that.

If you installed SW15 (which was not certified) then you might need to wipe data on Play Services to make it verify current certification levels again.

i will try this in a bit and report back. we NEEDED the security updates for work so she had no choice but to update to them as they came out. now i hope that 16 will not be the last one for a long time again and security goes way out of date or she will have to ditch the 2e again. where she works she is required to have her phone up to date to within i believe 2 months or less.

edit: nope that did not work either, she is to busy with her phone to re do it from scratch also. she uses it all day every day so she cant do that or i would have for her. it will still install but installs an older version (same one previously installed not the newest one) and then shows this message

Regarding Netflix, both my phone (on 5) and my wife’s phone (on 16) are seeing the same Netflix 7.107.0 build 5 35497 from June 9, 2021. Believe that’s up to date. If wiping Google Play Services wasn’t enough, try wiping both Google Play Services and Google Play Store data. It needs to get back to fully certified for Netflix to be happy.

The stated plan elsewhere in the forum is to have official releases every few months or faster, but someone official (aka, not me. :slight_smile: ) can state if that’s changed and there’s a plan for how many months is the official target.

right but she is not getting 7.107 build 5 35497 she is getting i think something like 7.97 etc thats the issue. even if she removes it and reinstalls it she gets the older version. it makes zero sense at all.

i also had my daughter check her 2e with sw16 and she never installed the betas (sw13, sw14, sw15) she went straight to sw16 and she also has netflix totally missing from the play store she cant install it because it doesnt even show up at all.