[Advanced] Installing factory Android image w/ SP Flash

SW6 was not the issue. When I attempt to wipe the data when in fastboot I receive the following error:

fastboot -w
wiping userdata…
Invalid logical-block-size 512: must be a power of 2 and at least 4096.
mke2fs 1.45.5 (07-Jan-2020)
/tmp/TemporaryFile-nKtgVK: Unimplemented ext2 library function while setting up superblock
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata

Also receiving this error if attempting to flash the system image. Are any of the newer 2e’s being shipped with different partition set ups that previous? I just received this device yesterday, 6/25/2021.

fastboot flash system system.img
target reported max download size of 134217728 bytes
sending sparse ‘system’ 1/14 (131068 KB)…
OKAY [ 4.068s]
writing ‘system’ 1/14…
FAILED (remote: This partition doesn’t exist)
finished. total time: 4.076s

I do now have TWRP sucessfully flashed and functioning.

EDIT: I have successfully installed iodeOS via a simple ADB sideload through TWRP. Hope I can get /e/ on here someday but I can’t figure it out as of now.

EDIT: Finally resolved my issue with help from aibd on /e/'s forms. It was an issue with me using the “System” Android tools and not the “Latest”. Purged the “System” and did commands ./from the “Latest” folder and fixed the issue. Thank you for the 2e, super excited for this project!

Congratulations, and I’m happy to know that you’ve successfully installed /e/ on your device! :smiley:

1 Like

I am running Debian 11.

When trying to run flash_tool.sh, I was getting an error message re: not finding libpng12-0.so.0 or similar.

symlink to current version did not work.

Tried to download and install the dpkg which was from Jessie. Had a multiarch-support dependency. Ugh.

Noticed there was a lib directory in the SP_Flash_Tool extracted directory. Opened the deb file with ark and extracted libpng12.so.0.50.0 to the SP_FlashTool’s lib directory and created a symbolic link for libpng12.so.0 to libpng12.so.0.50.0.

SP Flash then launched.

Maybe this can save someone else some pain and suffering.


Hey guys I run teracube one and have Mint 20 kernal 5.4.0-81-generic.

I have been trying to flash the teracube one to andriod nine and I only get this in the phone flash tool.

Any help would be greatly appreciated. I am out a phone now.


I’m assuming you don’t have access to a Windows 10 computer? Also - what version of SP Flash are you using and where did you get it from?

Hi egx470,
could you please explain the commands you have used to fix the issue. Sorry, I do not understand. Where are the “System” and “Latest” version ?
Could be usefull to describe the process for other Linux beginners :wink:
Many thanks

I’m having the boot-looping issue when I try to install the factory image, but the instructions for that case seem unclear. ‘When its screen is dark’? The screen is always dark when the phone is off. Am I supposed to turn the phone on and then try to time connecting it after the ‘dm-verity corruption’ etc. message comes up and it starts turning the phone off again?

Hi @degraine - apologies for the delayed response. The trick for a boot loop is to keep the PC ready in download mode and insert the cable into the phone as soon as the phone’s display turns dark.

I have done all the steps correct, I have windows 10 and all files but its saying to select at least one ROM file and I have selected all files, Please help how can I fix this.

It seems your firmware files are missing (look at the empty Location column in your screenshot). Are you sure you unzipped the full firmware and are selecting the scatter file from that folder?

@robert Hi!
Could you please fix the link to the Teracube One factory SW?

1 Like

Hi @kunicasport - thanks a ton for pointing that broken link :heart:. Fixed now.

1 Like

Thanks for this guide. Two things:

  1. The factory images linked seem to be somewhat dated (2020) for the Teracube 2e. Are there any updated images?
  2. Can the difference between the EU and the “rest of the world” image summarized briefly? (I suspect it to be either some privacy issue or competition issue as the EU has much better regulations regarding these two issues than the “rest of the word”)

6 posts were split to a new topic: T2e 2022 batch - how to restore to factory?

Worked for me, thank you!

1 Like


After some trouble with my phone I have flashed the stock ROM Teracube 2e 2022 following this how to and the process was successful. So my computer is able to detect the serial interface through the USB wire.

Now, I am facing to an issue where I am not able to reboot my device, the screen is black and nothing happens!

Have you some idea and advice for rebooting my device?

Thank you

Ok, I look good now. I am able to reboot to the stock ROM. I have another issue right now but I will add comment in another topic.

1 Like

After three months happily using /e/OS on my Teracube 2e (emerald), I started having severe network problems and decided to go back to factory Android using the How-to guide that links to this thread. SP Flash completed the process apparently successfully and the boot screen says “powered by Android” again, but all I can boot into is /e/ Recovery. Any ideas about what I did wrong and how to go about fixing it?

I’ve tried: flashing again, launching SP Flash as Administrator and flashing, factory resetting phone from Recovery.

As I recall, I installed /e/OS using ADB on Debian. I tried to install the factory image with SP Flash on Windows 10.


Hi @kbel - could you try this alternate process to install the factory OS?

1 Like

Thanks for highlighting that for me. I’ll try it out.
Edit: The alternate process appears to have worked! Thanks again.