[ Advanced ] Unlock the Bootloader

WARNING: Unlocking the bootloader WILL PERFORM A FACTORY RESET on your phone. Please backup your data BEFORE PROCEEDING.

Should you run into any issues, please post here.

Before you begin, please download the Following

Download platform-tools on your computer Android Developer or XDA

Note: The default Windows driver works most of the time but not always. If the default driver doesn’t work for you, install this one

Optional Windows drivers

MTK VCOM USB drivers here




**Bootloader Unlock**
  1. On Teracube, go to Settings > System > Developer Options.
    (If this is not already available, go to Settings > System > About and tap Build number ten times to unlock Developer Options. )
  2. Turn on OEM unlocking.

**Now Boot into Fastboot mode using either of these steps**

Use adb reboot bootloader

OR the following

  1. Shutdown the phone.
  2. Press Vol+ and Power buttons simultaneously for 5/6 seconds.
  3. You’ll see 3 options in tiny fonts. Use Vol+ to switch options.
  4. Select Fastboot and press Vol- to confirm. Now the phone is in Fastboot mode.
  • Perform the next steps on your computer
  1. Run fastboot flashing unlock in the platform-tools directory.
  2. A confirmation message will be displayed on the phone screen, press Vol+ to accept.
  3. The bootloader is now unlocked. You will see a message during the boot sequence each time you boot/reboot your phone (“Orange state”). This is an expected behavior.
2 Likes

Thank you for this! Would you mind linking to typical next step guides? (TWRP, full recovery image, etc)

1 Like

I have problems with getting my 2e connected to my Windows 10 PC so that “adb devices” shows my device when in fastboot mode. It simply does not show. I even installed the MTK VCOM USB drivers, but this did not help. When booting the device normally and connecting it to USB it is getting recognized by “adb devices”, but it is not after booting it into fastboot mode. Windows 10 device manager shows an “Android” device with an exclamation mark. Any hint? Would be much appreciated!

It’ll not respond to “adb devices” once it is in fastboot mode. You need “fastboot devices” at that point.

1 Like

Thanks! “fastboot devices” also did not show anything. But I got it working now!
By using the MediaTEK drivers available here:


The drivers mentioned in the posting under “Optional Windows drivers” seem not to work really.
3 Likes

Thanks a bunch for posting the new drivers.

1 Like

I tried the method above for about an hour, in which it went to fastboot fine, but kept ‘waiting on device’ when trying to flash unlock. Tried a couple of driver packs to no avail, but the Mediatek drivers worked! Thanks a lot for sharing that Jaxom! Maybe the guide can be updated with these drivers? Thanks again to Jaxom and Sharad for the helpful information!

2 Likes

Which one did you guys use @jaxom @Vlaflip ?

I used the setup ‘signed’ drivers.

Me, too. The Automatic installation.

I downloaded the drivers. Even though they say “signed”, the Windows security prompt said source: “Unknown”. Do you guys know any truly signed source?

Yes, sure you are right. I did take this risk. At least it was better than having to configure Windows 10 to not check drivers signatures at all to get the (not working) driver installed which is originally linked in the article… And sorry, no, I did not find any better source.

1 Like

Same for me.

1 Like

Sorry to bump this topic, but when I do the above instructions, I get “Unlock Failed”. I’m on Windows 7, and I have the Teracube 2e phone.

EDIT 6/5/2021
Nevermind, I didn’t see the instructions to go into the Developers menu and enable “OEM Unlock Bootloader”

1 Like

Should only download from trusted sources.

Scroll down to the MTK (aka MediaTek) section for driver download.

Thanks @SaraphimAngel for letting us know. Could you confirm if the download from Android Developers website work?