[Certified] Android 11.0.4 for Teracube 2e 1st batch (SN: 2020)

I haven’t tried 11.0.4 yet, but when I tried the new camera in 11.0.2 I noticed that a few features were missing (namely wide angle and QR code support) - were these added in?

Been on 11.0.4 a few days and things seem to be alright but have noticed these issues:
–I am not getting normal notifications for most apps (daily reminder for duolingo or fiton for example), and fewer notifications in general for others.
–I am STILL having the blink light issue, even though it is supposed to have been fixed. I have it turned off and when I first turned it off right after updating it stayed off for a little while but then came right back on, even when I have no notifications and full battery, it is blinking always, except now it kind of fades in and out rather than straight blink on and off
–I don’t love the new camera app. Before updating I kept both Teracube versions on my phone; while the original was very buggy, it did seem to take better quality photos in general, so I’m a little bummed that my photos just aren’t as good now. May need to switch to one of the other outside apps that people have suggested in the past.
Edit*: I’ll add that a lot of calls seem abnormally loud now. Even at the lowest volume it is sometimes bothersome and I go to turn it down to find that I’m already as low as it will go. And no, it’s not just loud people I’m talking to, I only talk to one or two of the same people frequently on the phone.

Just my early thoughts. Would be interested to see if other people are experiencing similar things as well.

Regarding Duolingo and Fiton and the other notifications, make sure you open Duraspeed from the bottom of Settings and allow any app for which you want background access. Note that under Android 10, Duraspeed had a bug where even it can’t be fully disabled. If you don’t like it, the closest you can do is to enable Duraspeed, choose Turn on all in the corner hamburger, disable Duraspeed.

Regarding the notification light, disabling “Blink light” does seem to remove that light. Also, "Don’t blink light’ in the Custom restrictions for DND mode. It doesn’t seem to be possible to disable the light for charging though, so it still needs to be face down when I’m trying to sleep.

Yeah mine still blinks even with both settings done that you mentioned.
Thanks for the tip on Duraspeed. I didn’t quite understand what it was when I was re-exploring settings after the update, but I’ve turned most apps on in it now.

Does anyone know? I think it was also missing the Panoramic feature… would love to upgrade, but don’t want to limit myself.

@Sharad?

QR Scan is in there. Other options are Camera, Video, Wide, and Pro. In terms of Panoramic, I’d just recommend installing Open Camera as it’s free and gives you Panorama and a variety of other fancy features.
For the base camera, it’s really just about being called from other apps, whether that’s for QR code scanning or quickly snapping a check or id card. Not having it constantly jump to Portrait mode on every launch is just icing on the cake.

1 Like

4 posts were split to a new topic: T2e 11.0.4 - texts issue on Public Mobile (Canada)

Are any future updates to be released anytime soon? Security patch level is getting old.

I am still waiting for the official FOTA release with updated security patches before I upgrade and haven’t heard any response in weeks.

Being kind and patient just gets you the cold shoulder.
I have been waiting for a security update for Android 10 for years now.

It seems to me that they don’t wish to retain their customers as they are not supporting their devices, which is a shame.

Not great 4 year support if you ask me.

We have started the 11.0.4 FOTA rollout. First, it is going out to all 11.0.x users and then we will move to SW16 users as well.

2 Likes

What’s the timeline for an Android 12 release?

2 Likes

Is there a way to downgrade to the previous update? I don’t like going without my live wallpaper :frowning:

1 Like

No, not in a seamless way without needing to fully reset the device, unfortunately.

I just upgraded to this version. Otherwise seemed seamless transition but my SIM card is not recognised at all. I tried both slots but it’s like they don’t even exist. Settings shows SIM status: Not available and IMEI is also blank.

Also, unfortunately I’m unable to send logs because the Developer options screen freezes when I try to enter it. “Settings isn’t responding.”

2 Likes

Could you tell us your country/carrier? For the logs, reboot and try again for the Developer options.

1 Like

Hi Sharad, I’ve tried multiple reboots. Unfortunately Developer options freezes every time. Unfortunately I don’t even have USB debugging switched on at the moment.

I’ve tried two SIMs: O3 (UK) and Tesco Mobile (UK). Both SIMs work fine in other phones. From the frontend it really appears like neither SIM slot is being recognised any more.

Edit: I guess my only option is to wipe it and reinstall 10. I was really hoping to avoid teething issues since this was tagged as [Certified].

1 Like

It is indeed surprising since many other users have already tested this build.

Before you revert to Android 10, could you please do a full factory reset to see if that fixes the issue? It should at least fix the Developer options (maybe the SIM as well).

1 Like

Sure, will do. I’ll post back results.

Edit: Good news is that a factory reset fixed both the SIM slot issue and developer options menu. It must have been some app or something on my Android 10 that made a mess of things.

1 Like

Just upgraded from iode os to official 11.0.4.

Everything seems fine so far. Security updates are a bit dated, waiting for 12. But apart from this, it’s fine. Thanks teracube!!

2 Likes