[Certified update] Android 10 for Teracube One!

Update: there is a newer build here.

Hi All,

Very glad to announce that our Android 10 build (10.0.0) for Teracube One is now Google certified.

Kudos to the Dev team, thanks for all Alpha/Beta testers and thanks to all T1 users for being patient. It took some time to get here (quite a lot I guess :slight_smile:). However, the team has done amazing work going from basic source code to fixing all issues, making the build stable, and finally passing GMS tests. This paves the way for our future Android work which should be way smoother from here. Infact, some early Android 11 work has already begun (no dates yet though).

Automatic update (OTA) coming soon. Till that time, you can install it using the steps below.


  1. April 2021 Security updates
  2. Android 10
  3. GMS certified

Known Issues (same as Beta 1.2)

  1. Settings has some extra benign options for “Pixel” (thanks Google). This is a configuration change that will be fixed soon.

Update: there is a newer build (check the message at the top of this post).

Archived Steps
  1. Download the upgrade zip file directly on the phone (or transfer the zip to the phone).

  2. Path to the update utility depends on your OS

Android 9 users
2.1 Goto Settings > System > About phone > Wireless Update
2.2 Click top-right 3 dots > Local updates

Android 10 Beta users
2.1 Goto Settings > System > Advanced > Teracube updater
2.2 Tap top-right 3 dots > Local update

  1. Tap “Internal storage” and browse to Downloads or wherever you transferred/downloaded the update zip file.
    Note 1 : If Internal storage does not show anything, then reboot the phone.
    Note 2 : Do not download the update to SD card.
  2. Select the file and continue the update process.
  3. Phone will power off and restart by itself. Don’t press power button.

Let us know how it went and post your questions/feedback here.


Thanks for getting the certification done. I am still having an issue setting up contactless payments on Google Pay. When trying to set up contactless payments (GPay-settings-contactless set up) the error “phone does not meet security requirements” is shown at the top of the setup page. All the required options are selected (see photo 1) and it does say “all set” below the white separator line. I am on Android 10, build 10.0.0. The Play Store settings do show the device as certified for Play Protect. I have done reboots, deleted and added back my cards, and anything else I can think to try. All to the same result- every payment method says not set up for contactless payments. Any thoughts on what the problem may be? Are others able to set up contactless payments on Google Pay?

1 Like

Congrats to the team and ALL involved in getting over this hurdle! Just wanted to report that the update went flawlessly and I have no issues to report. For anyone sitting on the fence about this update, just follow the instructions and be patient for the 8-10 minutes it takes to do its thing. Here’s to a smoother course ahead from here. Well done


Did you update from an uncertified build (example, from one of the betas), by any chance?
If yes, try wiping data and cache of Google Play Services and Google Play Store a couple of times. If not, please check if your bootloader is locked.

1 Like

Yes, I upgraded from the Beta build. My bootloader is however it was when it was shipped. I cleared both caches but am hesitant to wipe all my data in both apps unless this is the issue. Do you know that the problem is in the data or is this a best guess? I don’t want to get rid of the data and have that cause other problems, then need to do a full restore, if I can avoid that.


On device activation, GMS (Play Services) creates a unique device identifier that is also used to quickly identify whether a build is certified or not. Sometimes, the certification status does not get updated. Resetting the data of GMS and Play Store will force it to generate a new identifier and thus fetch the correct certification status. The only real “issue” you may see: after clearing data, you will have a notification that says “Add a backup account”. Just tap that and enable/disable Google Drive backups as per your preference :slight_smile:
TL;DR resetting it shouldn’t cause any major problems.

If you have Play Store saying that the device is certified and still get the contactless set-up warning in Google Pay, I’d suggest reinstalling Google Pay.
Let me know if the issues persist.

1 Like

Thanks, deleting pay and starting over looks like it did the trick. I will find out for sure when I go to pay but everything looks fine.


8 posts were split to a new topic: Cellular signal lower on T1 A10 than A9

A post was merged into an existing topic: Cellular signal lower on T1 A10 than A9

Not sure if this is an Android 10 thing or a Teracube thing but when I use to plug my phone in to charge the led light would be a solid red until it reached a full charge in which it would turn green. This was convenient because then you knew to unplug it so it didn’t sit on the charger longer than needed (battery life implications). The experience now is as soon as you plug it into the charge it’s green and it doesn’t change once at 100%, so no differentiation of currently charging and charging complete.

1 Like

It is the same for me. It makes the charging LED pretty useless.

1 Like

Yeah - that led pattern is a known issue. We had to put it slightly lower than everything else we fixed on our path to certification. Will get it looked at soon.


Makes sense for it to be lower on this list, good deal

Is there a boot.img file we can use with the upgrade to Android 10 to keep root?

You can install the latest 10.0.1 SP Flash version (download link). Instructions are here.

The zip also has the boot.img for repatching with magisk.

The 10.0.1 version fixes few issues over 10.0.0 (read here).

1 Like

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.