Instructions and 'boot.img' for installing Magisk onto SN2021 emerald?

Previously instructions for rooting / installing Magisk onto Teracube One, along with a link to download factory ‘boot.img’ have been posted here – [ Advanced ] Rooting Teracube One

Then a link for factory ‘boot.img’ for Teracube 2e has been posted here – Factory Images for the 2e but I think that one is only for SN2020, as posted back in February 2021.

So are there plans to post the factory ‘boot.img’ for the SN2021 emerald?

(So far the only thread I could find regarding installing Magisk successfully onto emerald is this one – [ Advanced ] Root Murena (/e/ OS preinstalled) Teracube 2e using Magisk (SN:2020 units) - #3 by ecs That thread was originally regarding installing Magisk onto SN2020, but additional posts were added regarding using the ‘boot.img’ from /e/ OS for emerald. However that method seems to only be compatible with running the /e/ OS, not the factory image.)

1 Like

You can extract the boot.img file directly from the factory image

1 Like

You can extract the boot.img file directly from the factory image

I already went looking for the factory image for SN2021 emerald but did not find it. It does not look to me like it was ever publicly posted. Are you saying otherwise?

1 Like

They put them in their “Auto-SW” package which you can find here:

The direct link seems to be:

and inside that looks like there’s a “Teracube_2e_A11_05_20211102” that has the relevant files such as boot.img

You’ll need to confirm for yourself if this is the correct image as I personally use the /e/ rom and can’t confirm for myself.


Ah indeed, that file does work. Thank you @Aje05

Filename also matches the build number of my phone if I go into ‘Settings’ → ‘About phone’ → ‘Build number’.

So yeah, downloaded, extracted ‘boot.img’, and followed the instructions at Installation | Magisk

Downloaded with my computer and pushed it onto the phone to ‘/sdcard/’ using ‘adb’. Also pushed the extracted ‘boot.img’. After having the Magisk app patch ‘boot.img’, adb-pulled the patched file back to the computer, now ‘magisk_patched-[random_strings].img’, did ‘adb reboot fastboot’, and then ‘fastboot flash boot magisk_patched-[random_strings].img’ as in the instructions.

Rebooted back into system, did ‘adb shell’ followed by ‘su’ and can confirm that now have the root prompt ‘#’.

Obviously prior to this had to unlock the bootloader as described at [ Advanced ] Unlock the Bootloader

The only thing I had a problem with is getting the bootloader locked again. Attempted to accomplish that by going back to fastboot and then doing ‘fastboot flashing lock’. That command itself worked, but when I tried to boot back into the system it flashed an error regarding verification problems and went into a boot loop. So I got back into fastboot mode and issued command 'fastboot flashing unlock'. That allowed me to get back into the system but of course the bootloader is still unlocked. Messing with the bootloader locking also did a factory reset; however, the phone is still rooted. I pushed ‘Magisk-v25.2.apk’ back to ‘/sdcard/’ and re-installed it, and it still detects itself on the boot partition and ‘adb shell’ still allows ‘su’. I attempted to disable the verification using the command ‘fastboot flash vbmeta --disable-verity --disable-verification vbmeta.img’ as in the Magisk installation instructions but that kept failing with ‘FAILED (remote: 'No such file or directory')

So hope this is useful to whoever is also rooting their Teracube emerald. Much appreciation to @Aje05 for pointing out where the factory image is. Very glad to finally have found a phone that allows root access and user-replaceable parts.