Not able to answer a phone call

I have used Android smartphones since about 2011. But in my world, using the phone is more about data and computing, web access and such. I receive/make few actual phone calls.

It now seems the world has shifted a bit, and making/receiving phone calls is more the norm than it used to be.

So, when I receive a phone call, how do I answer? Often a call will come in while I have some app open on the screen. I get a small window with a “Answer” button and a “Decline” button. When I tap the “Answer” button, the small window closes, the screen goes back to what it was, the phone keeps ringing, and I cannot find the phone app running anywhere. Usually, I have to wait for the caller to give up, the ringing to stop. Then I open the phone app, look for the most recent call and call them back.

It’s awkward, and I feel like an idiot, but when the phone starts ringing, where is the place that I need to answer?

That is not expected and could have happened prior to SW6. Could you confirm if you have the latest SW6 update (Settings > System > About > Wireless update).

The only thing I see is “Current

My phone app has behaved this way for months now. No longer sure whether the behavior dates back to the initial delivery of the Teracube.

– Mike

Lets check Phone app permissions and clear its storage.

  1. Settings > Apps & notifications > Phone > Notifications should be On.
  2. While there (inside Phone app info), click on storage and Clear cache and storage.
  3. Reboot and try an incoming call.
  4. If this doesn’t work, then we can try usual steps of first doing a cache cleanup and if still needed - a factory reset.

I did steps 1, 2, 3. When the test call came I got the Decline and Answer buttons as usual. When I tapped on Answer the phone app then came to the front and I could proceed with the call.

So, I seem to be good now.

Thanks for your help.


1 Like

Clearing the phone App cache worked for me. Thanks for the tip!