Guide to install iode OS on Teracube 2e (SN:2021) using a Mac and terminal

A more comprehensive guide on how to install iode from stock OS on terracube

Prerequisites

  1. Update the stock firmware on teracube to the latest
  2. Follow Unlock the Bootloader
  3. If you are not in fastboot mode, then enter fastboot mode again
  4. Type fastboot flash boot iode-emerald-recovery.img and press enter… (make sure you have the latest iode-emerald-recovery.img, filename can be different)
  5. Reboot to recovery using fastboot reboot
  6. You will see an iode OS recovery page. From recovery => Factory reset => Format Data/factory reset
  7. Go back to the main recovery page, then from recovery => Apply update => Apply from ADB => type in adb sideload hit the spacebar and drag in latest [iode-emerald.zip] into terminal and hit enter. This will take 5-10 minutes to complete.
  8. Once the installation has been completed, go back to the recovery page and hit reboot, and you should have iode installed.

Please comment below if you have edits or further instructions, and I will add them to the guide.

Best of luck! :grinning:

1 Like

I saw on the website only the 2021 / 2022 version. (iodéOS installation - iodé)

Does this installation for the 2020 (Zirconia) model?

@curiousAndreas Not that I have seen. You’d have to contact the iode OS developers to see if you could use the 2021 installation guide and files or if they have separate support for the 2020 model. Doesn’t look like it.

The same instructions may not work for Zirconia (2020) and may damage the partition table. Please be careful.

1 Like

WARNING: Left out this crucial important step below. Can’t seem to edit the post!

Step 3 should be: Settings > system > advanced > developer options > enable OEM unlocking and USB debugging.

Check out this guide for the missing steps: [ Advanced ] Unlock the Bootloader

1 Like

I changed your steps a bit in the original post. Let me know if the changes look good.

Perfect thanks. I was going to link but I wasn’t able to add more than two links.
It will need an edit tho as I have completed the installation but the phone was corrupted. Waiting to hear back from the iode devs to see why. There are no further instructions from them on their basic guide.

1 Like

I recommend this guide if you want to start from a clean state again.

After trying to install multiple times and receiving no help from the iode community this guide appears to be incomplete.

All attempts have ended in corruption of the phone so far and having to revert back to stock OS.

The following errors show up on the iode recovery screen:
" Failed to mount/metadata: invalid argument"
" Cannot mount / metadata/ota"

If anyone knows what is missing/wrong with the guide. Please share.

I’m completely unable to install IodeOS as well. No matter what I do, I end up with a dm-verity corruption message and failure to boot (and have to flash the stock image).

In my case, just having the IodeOS recovery image flashed was enough to cause the boot failure – that’s with the rest of the software being totally stock. So I thought I’d try installing IodeOS, and then flashing the LineageOS recovery image (which works for me) once it was installed. This didn’t work either.

Hope this gets sorted out, cause this ROM seems exciting!

@Sharad
I’ve just bought my Teracube 2e 2022 !

I’ve tried 3 times to install the iodé OS
always the same problem :
" 94% adb failed : no error"

but it’s impossible to boot in normal way.

is this issue known ?
what’s the recommendation ?

Hi all,
Happy New Year !

I’ve just bought my Teracube 2e 2022 and I wanted to change my OS///

I’ve tried 3 times to install the iodé OS
always the same problem :
" 94% adb failed : no error"

but it’s impossible to boot in normal way.

Is this current that the installation of the OS is not completing ?
Anyone knows where is the recurring issue that can be easily corrected ?

I’ve respected all steps, very well explained here, but always it’s the same… blocked at 94 %…

Thanks for the help !!!

Gabo

1 Like

Hi @GABO_CU84 - welcome to Teracube forums. I’ll ask Iode folks to help here.

1 Like

Thanks for your support

really, as the installation is locked at 94%, it’s impossible to reboot
it propose me turn off the phone after 5 seconds because the OS is not stable

Do you had any feedback from IODE ?
I did tryed to install iode-2.9-20221215-emerald.zip on the latest TERACUBE 2e Version

Maybe, these aren’t compatible yet ?

Unfortunately, it appears iode still hasn’t sorted this out, so although the instructions are correct, the ROM will not install correctly. Such a shame as it works very well on a fairphone.

1 Like

Hi @GABO_CU84 - I’m sorry but we have not heard back from Iode folks. If you are still stuck, you could always go back to the factory ROM using these steps.

Hi,
Sorry for answering a bit late.
Although at some point in time our builds for the 2e 2nd batch could boot fine with the given procedure, this is no longer the case and we don’t manage to understand why.
iodé can though be installed with the spflash tool, and the zip file here: https://github.com/vincentvidal/iode_ota/releases/download/v1/emerald-spflash-2.9.zip
Once that’s done, OTA updates work perfectly.

1 Like

Hi


iode