Signal (the app) issues on Teracube 2e

Hey pals!

Got my new 2e a week and some change ago and for the most part it has been great. Signal is causing a bit of a headache, though. The main thing is that about 90% of the time I only get notifications once I open the app. IE: got a message 50 minutes ago, no notification, open Signal, message doesn’t show immediately, then it pops up (as if Signal has just downloaded the message).

In terms of troubleshooting on my end: I enabled all permissions, turned off battery optimization, and allowed unrestricted data use. All notifications are enabled in both Android and Signal. Do Not Disturb mode is NOT on. Battery manager is off. I’ve tried it with and without “Android Adaptive Notifications” turned on in the Special App access area. The issues happen regardless of if I’m on WiFi or T-Mobile LTE. I’ve tried uninstalling/reinstalling, clearing storage+cache, etc. I tried what I found on the Signal website to no avail.

Anyone have any ideas? Thank you in advance!

EDIT: trying it out again after booting into recovery and wiping the cache partition after seeing that idea in an unrelated topic. Will keep y’all updated but still happy to hear from anyone!

1 Like

Did your previous phone get notifications right away? Tried out Signal on my 2e unit for a day. It’s been working fine - receiving messages and raising notifications after few hours of putting down the phone. I’ll be asking one of our Software devs to try it out as well.

Any other 2e users using Signal with their phone?

1 Like

Yup, previous phone was an LG K51 on Android 10, all good on the notifications. To be honest, I think I’m having an issue with any sort of notifications related to receiving content on the entire phone, Signal is just the most prominent of them since I use it the most for communication. I did some tests on Gmail and Fastmail today and their notifications were very inconsistent (some received emails gave a notification within a minute or so, others gave no notification). I just cleared all data from and reverted Google Play Services back to original and then updated it to the newest version, so I’ll keep y’all posted on that. Also worth noting DuraSpeed is off as well, I haven’t turned it on yet.

Just to confirm - have you done a factory reset? If not, please go ahead and try that as well.

This may be relevant.

I don’t use Signal much but I remembered seeing this over on reddit. Seems you’re not alone.

Factory reset is the nuclear option to me, so I wanted to exhaust every option before trying it. I wiped the partition cache and did a factory reset over the weekend and I’m still having the issue, sadly. Signal, Fastmail, and Gmail are the ones that I can 100% confirm have issues for me. I gave it a couple days before messing with settings, then tried basically everything detailed in my first post again to no avail. :frowning:

It is best to go ahead with a factory reset and see if the issue persists. We have not had any other users report such behaviour (especially across multiple apps). So it could be some weird state which factory reset should clear up.

Sorry, should’ve made it more clear in the last message:

I did a factory reset on Sunday and this remains an issue for me.

Here are the next things to try:

  1. Make sure you do not have Duraspeed enabled.
  2. Try safe mode and see if your Gmail works reliably.
  3. Enable developer options. Whenever the issue happens again with the Signal app, collect logs (howto) and share with

Awesome, I will keep y’all posted. Thank you!

Same issue here. It is very annoying. Especially if you also use the desktop signal client. I had a long chat that was and the signal on teracube 2e did nothing. No sound, no alerts etc. Which would be fine if it was syncing and know messages are read but it doesn’t. Instead signal sync a when it opens now and can take forever to catch up… 5minutes for today’s.

Only had this issue on teracube. My work phone, samsung s9 and my old pixel 2 work fine. Even if I have the old pixel on WiFi it stays up to date.

1 Like

Update: Thank you for sharing the logs. And we were able to reproduce the issue as well. Based on the initial assessment indicates that our system is doing the right thing. This is an ongoing issue with the Signal app. We will continue to monitor this issue.



I’m very glad they were helpful and let y’all recreate that error! Hopefully things get better soon from Signal’s end.

However, I’m still having that same issue with Gmail and Fastmail. I’ve set them to “not optimized” in the battery area and given them both unrestricted data so maybe that will fix it on my phone now that is has been factory reset. Either way, I will send another log the next time that happens.

1 Like

In case it helps anyone: after exhausting every option save for Google account reset or factory reset, I found that I had to do the following:

  1. Set Signal’s battery optimization to not optimized / unrestricted in the app’s Android settings, AND…
  2. Even though I had never enabled Duraspeed, I had to enable Duraspeed, and then add Signal to the list of unrestricted apps within Duraspeed itself.

I don’t know if this implies that Duraspeed is always active to some degree, or is somehow in conflict with the Android system battery optimization, or maybe just enough time passed and Signal just happened to update with a fix specific to my Teracube 2e.

Good luck, otherwise!


I was still having this issue (and had just upgraded to SW16), so I am giving this a try. I’ll report back in a bit to say if it worked or not but certainly does explain some of the other notification issues I was having.

Just wanted to mention this appears to be the trick for having (the privacy-hostile) Life360 app function as intended.

I’m adding the shout-out here for anyone else searching the forum for the Life 360 app- no doubt this config applies to other apps too.


1 Like

A post was split to a new topic: Signal (app) on Teracube One Android 10