Wi-Fi Calling on Dropdown menu missing?

ahoy all and first thanks to Teracube for moving toward a more sustainable phone, and one that is way more open!

i am seeing the same issue with the Wi-Fi callling not working here on Teracube_2e_16 but with a T-Mobile network:

  • when Airplane mode is activated Wi-Fi calling is disabled, even after re-activating Wi-Fi and Airplane mode
  • when Airplane mode is activated and then Wi-Fi (and then Wi-Fi calling again due to above issue) enabled, trying to make a call results in a “you must exit Airplane mode to make a call” message.

this is a pretty important feature for us so wondering if there has been any progress on a SW fix?

thanks again and take care!

1 Like

Hi @waynedpj - welcome to Teracube forums. Yes - I tried this out as well on my T1 today and it works the same as you mentioned. Wifi calling is not working in airplane mode (with Wifi on).

I’ll check with the devs if there is something special in our code to block this. Do you happen to have any other Android 10+ phones that have this working?

ahoy @Sharad and thanks for the reply. unfortunately our previous phone was only supported until Android 5.x but it did have working Wi-Fi calling and txting. and while i will try to see if i can find an Android 10 to test, it is unlikely as most of our circles are caught in the Apple walled garden :slight_smile:

thanks again, w

My wife’s Pixel 4a with Android 11 works properly (Airplane mode ON, wifi ON, and it dials out). It does look like Android moved the wifi calling selection into settings for 10 and up, but it should be on by default.

I think this might be another side-effect of the Joyn ap, as wifi calling worked prior to the firmware update when the Joyn ap got forced on us. Some Google searching says wifi calling is both hardware and provider dependent, and so I wonder if AT&T gimped the feature if you refuse to use Joyn.

The Joyn app has nothing to do with Wifi calling. As I mentioned earlier, AT&T enforces no wifi calling policy on all BYOD phones. Hence we had to specifically configure it such that it is not shown for AT&T (it’ll not work even if its there).

A post was split to a new topic: Wifi calling not working on O2 SIM?

What? A fundamental component of any modern phone has been borked to cater to just one carrier in the world? Not to make too fine of a point, but screw AT&T. If I wanted to be locked into their terrible service, I would’ve signed up for them a long time ago. This literally costs me money. Now when I’m out of the country on business, instead of being able to connect to WiFi and make standard calls I have to pay to roam.

The camera issues are a nuisance; this is a basic operational failure. Completely unacceptable.

while i understand that there will be growing pains with a new company and products, we just invested in 2x 2e phones to support the mission, success, etc. of Teracube. and like others the use of Wi-Fi calling/txting is essential. what’s more is that it was working recently before the latest update. @Sharad if there is not a quick fix/update pending, can we at least go back to a previous version of the system software where Wi-Fi calling works, and if so how?


1 Like

The behavior seems NOT unique to Terracube: On a Ulefone Armor X8 with Android 10, over Ting/T-Mobile, wifi calling does NOT work if in airplane mode, and wifi on. As with @waynedpj , I get the message: “you must exit Airplane mode to make a call”

Hi @Dake and others - I want to make sure everyone is on the same page here. Teracube 2e still supports Wifi calling on all carriers except AT&T.

If you put an AT&T SIM, then you will not see wifi calling because of AT&T’s requirements. There might be some other phones out there that do support wifi calling on AT&T but they may be AT&T branded phones (or big brands who have a special deal).

There is nothing we could do here for AT&T - its their certification, their rules. If we didn’t comply, they wouldn’t certify us for HD calling and which would have meant that Teracube 2e would just not work with AT&T and Cricket.

Unfortunately that doesn’t appear to be accurate. I’m on T-mobile and lost WiFi calling with the last update. It worked before SW16 and is gone now.

@Sharad like @Dake i am also on T-Mobile and Wi-Fi Calling is not working on SW16:

  • i can see the Wi-Fi Calling settings only when the phone is not in Airplane Mode
  • once the phone goes in Airplane Mode (which turns off Wi-Fi) and i turn Wi-Fi back on, the Wi-Fi Calling settings are gone and i cannot make calls over Wi-Fi

please let me know if you need any more information to help resolve this issue.


Thanks for clarifying. Wifi calling is working in general. However, it’s not working in the special case of airplane mode (cellular turned off) and Wifi on.

We are looking into it. However, the actual fix might take some time. If this is a blocker for some folks, then please roll back to SW6.

Also curious as to what scenarios do folks use this mode (airplane mode with wifi on)? Roaming seems to be one. Where else is this useful?

i am sorry if i was not clear but as i tried to say from the beginning Wi-Fi calling is NOT working at all on our 2e with T-Mobile, whether in Airplane Mode or not. when not in Airplane Mode and with Wi-Fi enabled i can see and change the settings, but the Wi-Fi calling always just says “Call over mobile network”

and when clicking on “Wi-Fi Calling” there is a big blank space where i assume there should be options to prefer calling over mobile, Wi-Fi, etc.

also on other phones with this SIM, when Wi-Fi Calling is working we see the carrier name in the upper left corner with Airplane Mode on with Wi-Fi enabled, something we have never seen on this 2e thus far.

i did notice today that if i put the 2e in Airplane and quickly re-enable Wi-Fi i can catch the Wi-Fi Calling settings before they disappear, and actually select between calling over Wi-Fi or mobile

however as discussed earlier in this thread, if i try to make a call i receive a dialog saying that calls cannot be made because Airplane Mode is enabled, even though as you can see the settings say “Call over Wi-Fi”.

i hope this makes things clear for at least my situation.


Hi @waynedpj - is this TMobile EU or TMobile US? And yes - that does seem something is not working right in there. The Wifi calling setting should have option in there to select the priority (over wifi or over cellular).

Can you try removing your Vodafone SIM card, reboot and check again. In the meantime, I’ll ask the Devs to see if they would like to get a bug report from you.

I’ll just throw in that my phone behaves the same as Wayne’s. It’s Tmobile USA and I do not have any additional sims installed.

And to answer your earlier question:

Also curious as to what scenarios do folks use this mode (airplane mode with wifi on)? Roaming seems to be one. Where else is this useful?

Roaming is the primary reason, specifically internationally. When I’m in a hotel overseas I will put my phone in airplane mode and turn on the WiFi. W/WiFi calling enabled, regular texts or calls will then still come through, but I can be confident I’m not using my more expensive international rates. The other place I used it is actually ON airplanes connected to the aircraft’s WiFi and for similar reasons (though in this case just to be connected at all).

@Dake and @waynedpj - could you share logs? I checked on my TMobile connection, Wifi calling has a setting that allows to select “call over LTE or call over Wifi”.

Sharad, that’s what my T2e shows (I’m on T-Mobile as well), even though the /e/OS currently does not support VoWiFi. Hopefully devs can get that sorted soon! :crossed_fingers:

I have those options, but even when I tell it to use Wi-Fi only, as soon as airplane mode turns on (with Wi-Fi on and connected), those options go away (as in no longer even shown) and it will no longer make calls.


Ok so this is weird. I got it to work. I think this is what I did…

I had to be on the settings>network and internet>mobile network.

Went to Wi-Fi calling. Turned it on and selected Wi-Fi only. Then I turned on airplane mode. The first time I did it the settings disappeared, but I did it a second time and it actually worked. The nuisance is, I had to reboot the phone to get it back to normal as initially, I turned airplane mode off, turned Wi-Fi calling off, and it still wouldn’t connect to cellular.

UPDATE 2: Ok yeah, I’ve managed to do it again, but it’s clear something doesn’t like it. Once you’ve “tricked” the phone into Wi-Fi calling only, you have to reboot to get it back to normal. Just putting the settings back will prevent it from connecting to the network.

I can’t really sit down and do a bunch of screen caps at the moment, maybe later tonight.

Super. weird

Got it. Yeah - wifi calling in airplane mode is just not working/enabled at this point. We will look into it in Android 11 (being worked on right now).