[Beta] Android 13 for Teracube 2e

We have a newer Beta 2 out.


** Warning **

  1. Please backup your data before proceeding.
  2. Not for the faint-hearted. This is Beta software. If something goes wrong, you might lose your data and might have to re-flash factory Android (instructions at the bottom of this post).
  3. Read the notes before you install.

Excited to release this 1st beta of Android 13 for T2e. Comes with the latest security patches (July 2023). Looking for beta testers to help us test it out.

What works

  1. Android 13 + July 2023 security update
  2. VoLTE, wifi, and Bluetooth have all been tested
  3. Upgrade from Android 10, 11 and 12.1 has been tested in the lab
  4. Stable and smooth

Known issues/changes - do read before proceeding

  1. Your wallpaper and home screen will change from what they were on previous Android
  2. Vowifi (wifi calling) does not work yet
  3. Build is not certified.


  1. Download the upgrade zip file directly on the phone (or transfer the zip to the phone).
    Emerald link (SN:2021)
    Zirconia 12.1 users - Read here first.
    All other Zirconia users
  2. Goto Settings > System > Teracube Updater
  3. Click top-right 3 dots > Local update
  4. Tap “Internal storage” and browse to Downloads or wherever you transferred/downloaded the update zip file.
    Note 1 : If Internal storage does not show anything, then reboot the phone.
    Note 2 : Do not download the update to SD card.
  5. Select the file and continue the update process.
    Note: If the Updater closes or crashes, then try again.
  6. Upgrade process will take a while.
  7. Reboot the phone after the updater says “Update installed”.

Let us know how it went and post your questions/feedback here. Please keep the comments related to this update itself.

If you experience any errors/issues, you can flash the original factory firmware using the automated installer or SP Flash.


I’ll be testing on both my 2e units (2020/2021) here over the next week.

This is exciting!

1 Like

I gave it a try and was unable to install the image. Once the file was selected there was a preparation stage and then the final msg was about how the phone was going to go into recovery mode to perform the install. Once I clicked on ok, it just looped back to the preparation stage. I rebooted a few times, re-downloaded the file but could not get all the way through the install. I tried to go into recovery to see if I could install the image from there but apparently I don’t have a recovery installed. I have never done anything on this phone with the boot loader or recovery so I don’t know why it would be gone. Anyway, take a look at the screen grabs I attached. I did note the update identified itself as 12.1.0 (as shown in 05.png)


I’ll have the Dev look into this for Zirconia units.


Download folder shows 13.0.0+e8od34a zirconia, updater shows it as 12.1 file, did not update until this problem is clear up​:thinking::grin:


Update: Zirconia is back with a note.

Yes - Zirconia upgrade is broken. Will provide updated Zirconia instructions soon. Changing the OP.


Thankyou for latest Android 13 on my 2e it should give new life to this phone
@Sharad however I live in countryside and vowifi feature is must for me i loose connectivity with my sim network thus i use vowifi feature, since purchased i’m on Android 10 version 06 can we expect fix soon for this?

Thanks to your efforts & to keep longevity of 2e

1 Like

I’m still too scared to update and lose all my data since Teracube is my main phone and even a day without it would cause troubles, do you think a stable non-beta Android 13 release will happen before 2024? I’m also worried about security updates…

1 Like

Yes - work is in progress on that. Will update back soon.


Zirconia Android 12.1 users (SN:2020)

  1. Please download and install this Updater apk. [This fixes a bug in the 12.1 updater]

  2. Now follow the regular instructions for Zirconia.


@GMark and @ron77 - Zirconia update is back. If you are on Android 12.1, then you need to install an apk first to fix the updater. Read the above post.


Emerald did the upgrade from stock Android 11 to Android 13 Beta without issue.
Zirconia did the upgrade from stock Android 12.1 (with updated Upater APK fix) without issue.

Of note, QuickStep customization was lost (but we were made aware of this).

Database migration for Phone/Messaging seems to have gone over fine, and all apps are working fine after, and some even have updates that were held (I guess some updates are only valid for Android 12+).

Passmark Performance Test Android
Emerald (Android 13):
System: 3,663
CPU: 1,923
Memory: 5,266
Disk: 30,302
2D Graphics: 6,215
3D Graphics: 2,926
Baseline: 8065721

Zirconia (Android 13):
System: 3,717
CPU: 1,984
Memory: 5,280
Disk: 26,203
2D Graphics: 6,040
3D Graphics: 2,766
Baseline: 8065722

1 Like

Hmm was running android beta 13 for about 14 hours before phone when into recovery mode. Stated system corrupted do a factory reset. Will do a update later :confused::yum:

1 Like

Was able to get micro SD card Data saved :grinning::+1:t5:

1 Like

That’s really unfortunate!

What version did you update from?

Have you had any issues prior?

No problem before today, running ziconia final beta 12.1 to 13 Beta. Also updated the updater before APK fix

1 Like

with APK Fix first

1 Like

So back from a system reset booted into: running 13.0.0.dfea79b zirconia, android security update:7/5/23, Google play system update 8/1/22. Phone fm radio app back but not working, everything else seems to be working :face_with_monocle::yum:


The Updater update did the trick. I initially tried to do the local update which failed but when I restarted the phone, the update succeeded. It looks pretty good so far. :+1: