[Certified] Android 11 for Teracube 2e 1st batch (SN: 2020)

Note: There is a newer 11.0.4 update available now.

Archive

Note : This update is for the 1st batch of T2e (SN:2020)

** Warning **

  1. Please backup your data before proceeding.

  2. Check Known issues below before proceeding.

Here is our 1st stable and (Google) certified Android 11 for Teracube 2e (1st batch; SN 2020). Even more performance improvements and bug fixes over the Beta release. We are continuing to work on the next update.

What works

  1. Google Certified - so Google Pay, Netflix, Disney+ all work.
  2. Will work for all regions (US, Canada, UK, EU, Rest of the world)
  3. Bluetooth music and calling, NFC, WiFi, Cellular, VoLTE - all work
  4. Notification LED behavior fixed.
  5. Bluetooth range and music skipping issues should be fixed.

Known issues - What does not work yet

  1. FM does not work
  2. Hotspot
  3. Not a bug but more of an Android 11 feature. SIM cards can’t be disabled individually for Dual SIM setups.
  4. Performance is still being tuned. You may experience some slowdowns.

Steps

  1. Download the upgrade zip file directly on the phone (or transfer the zip to the phone).
  2. Goto Settings > System > Teracube Updater
  3. Click top-right 3 dots > Local update
  4. Tap “Internal storage” and browse to Downloads or wherever you transferred/downloaded the update zip file.
    Note 1 : If Internal storage does not show anything, then reboot the phone.
    Note 2 : Do not download the update to SD card.
  5. Select the file and continue the update process.
  6. It will take a while. The phone will power off and restart by itself. Don’t press power button.

Let us know how it went and post your questions/feedback here. Please keep the comments related to this update itself.

If you experience any errors/issues, you can flash SW6 (original Android 10 firmware) using these instructions.

5 Likes

Hello,

for me the update was running without problems.

Thanks

2 Likes

Everything went well with mine also. APN and contact list were intact AND that indicator light is working properly! I also tried 2 separate FM Radio apps (F-droid and Linoges) but no-go on that. That is one stubborn chip in there that’ll have to wait for it’s update. Good work team.

2 Likes

Update went smoothly.

However, hotspot capability is reduced to no devices being able to connect due to “IP configuration failure”. It also shows as “off” under (settings> Network & Internet> Hotspot & Tethering) whether it is turned on or off.

As someone affected by AT&T’s 3G shutdown, prior to updating my phone I was able to edit APN settings to make hotspot tethering work. Now neither APN edit allows a functioning hotspot.

2 Likes

So far, so good. Update was seamless & no data/settings lost. I’m on Mint Mobile so it’s T-Mobile’s network. I’m also traveling this week and I’ll do my best to pay attention to how the network connection performs vs my other phone (Google Pixel 3aXL also on Mint Mobile). It seemed identical on the last beta version so I expect it to be the same now. Hopefully.

2 Likes

Thanks for reporting the hotspot issue @J5d. Devs are looking into it and should be able to fix it by the next build. If we need logs, I’ll message you.

1 Like

Thanks for the good work on the update, look forward to getting it on the phone. But the updater keeps crashing. Please advise. Cheers.

1 Like

Hi @lgm - can you check/try few things:

  1. Is your SN starting with 2020?
  2. Goto Settings > Apps & notifications > See all apps > Search for “updater” > Goto Teracube Updater > Storage and Cache > Clear Storage
  3. Reboot your phone and try again.

Thanks. Got it installed!

1 Like

Update went well, but it took a few minutes to recognize the SIM cards. Kept saying “Emergency Calls Only” and setting showed no SIM cards. After a few power cycles and restarted the phone and left it my pocket while shopping. Both SIM cards were being recognized after about 15 minutes. I had to enable mobile data to get things to work after that.

No other issues. Looks good so far.

Interstingly, when I went to Update it offered a download of a previous version (but newer than what was on my phone - I didn’t realize it’s been a year since I last used my Teracube 2E!) but I ignored that and went for the local update. Didn’t even have to browse - it found the file itself. I hope it’s OK that I skipped the other one - I suppose if I had to upgrade incrementally it would have complained.

BTW, will this version eventually be offered as a download from the Update page in settings?

Update complete - seems to work, EXCEPT all of my apps and widgets (except for the defaults) are missing from the home screen, and no additional home screen(s) when swiping left. Rebooted again and still not there. They’re all installed and in the “app drawer” - I guess I just need to rebuild my homescreens. I don’t think I’ve ever had that happen before when updating Android - sometimes an app or two might be missing or misplaced, but never does it take me to a (near?) virgin home screen. Wallpaper is fine tho, lol.

Well, for me this did not work. I still only get installation error messages.
The Updater notification says: “Teracube - 6 May 54251 Install error”
I am currently running Teracube_2e_A11_EEA_01 on my phone. Might have something to do with me running this version?

it resets the launcher mostly you simply need to re drag them to the panels you want them on. they are all there just not on the launcher panels anymore.

I even tried to go back from by 11 Beta to the Android 10 version, but Flash Tool then tells me “PMT changed for the ROM; it must be downloaded. Please select “Format All + Download” scene and try again.”
But there is only the “Download Only” option available…

Thanks much to the Teracube team for fixing my very special case issue! I’m happy now using the latest version on my 2020 model phone!

Updated well here, too.

I have 2 SIMs installed. After the restart I needed to re-enable my SIMs and select the services they should be used to provide e.g calls, SMS and data.

As mentioned by others, above, my home screen widgets / app icons were reset. I’m not concerned by that. It’s just mildly annoying and amusing because I only organised them a couple of weeks back.

So far, so good. Thank you.

1 Like

Updated two Teracubes, no problem. Only changes was the need to update my wallpaper.

It worked fine for me, except mobile data. Had to add an APN. Now it works.
More info in this post, for anyone who needs it: https://community.myteracube.com/t/working-now-no-mobile-data/2958/7

1 Like

Something to add.
The ‘new’ camera app didn’t work for me right away.
I reset the camera data (delete user info & cache in the app settings of Android).
Now it works.
And yes, finally, I can scan QR-codes from the camera app!!!
On my previous phone, it was automatically searching for QR-codes, but this works too.

There is still a glitch with the beauty setting.
Can I add info about it here on the forums or is this a Android 11 issue?

2 Likes

Sure - could you create a new topic in “Teracube 2e” category to share feedback on the camera app.