[Certified][A10] SW update - 10.0.2 for Teracube One

We have a new bug fix update for T1. This build fixes the following over 10.0.1

  1. WiFi Calling (WFC) feature for supported carriers
  2. AT&T Certification and compliance
  3. Fixes for various carriers, enables IMS for most supported carriers

** Existing Android 10 users, please note: **
Due to a few technical limitations, users already on Android 10 may need to factory reset in order to use WFC and other telephony fixes in this update.

Prerequisites: Make sure your phone is sufficiently charged.


  1. Download the upgrade zip file directly on the phone (or transfer the zip to the phone).
  2. Path to the update utility depends on your OS

Android 9 Users

  1. Goto Settings > System > About phone > Wireless Update
  2. Click top-right 3 dots > Local Updates

Android 10 (Beta and 10.0.*) users

  1. Goto Settings > System > Advanced > Teracube updater
  2. Tap top-right 3 dots > Local update
  1. Tap “Internal storage” and browse to Downloads or wherever you transferred/downloaded the update zip file.
    Note 1 : If Internal storage does not show anything, please try restarting the phone.
    Note 2 : Do not download the update to SD card.
  2. Select the file and continue the update process.
  3. Phone will power off and restart by itself. Don’t press the power button or interrupt the update process.

If you run into any issues (carrier-related or otherwise), then please share logs.

Let us know how it went and post your questions/feedback here.


I have been facing Bluetooth issues since upgraded to Android 10. Media is playing fine on BT, where as calls are not ! I tried resetting Wifi, Network and Bluetooth settings , but still no luck. Please help !

Could you share what kind of issues are you facing during the calls?

I’m receiving an error every time I try to manually install the update. I have 10.1.0, which means that I may have to factory reset?

@BrianW - are you trying to install 10.0.2 over 10.1.0? 10.1.0 is the latest build so you can’t install an older build on top of that.

1 Like

@Sharad Is the 10.1.0 build stable for T1 users, I thought it was in beta? Can T1 users update to the 11 build just released for T2 or are there compatibility issues between the 2 phones?

1 Like

Still beta, but I’ve personally deployed it to 4 phones for myself and family and have found it to be stable.

As for Android 11, the ROM for the 2E is not compatible as the hardware platforms are completely different. Future ROMs will use a shared base, but that has not been released yet.

So in summary, 10.0.2 is latest stable, 10.1.0 is latest beta, and that’s what we have.

1 Like

Looking forward to the next Teracube One release. :slightly_smiling_face:


Teracube One 10.1.0 is a rock solid update. It works absolutely fine here - you can update without hesitation :smiley:


I’m running LineageOS on my One and thinking of switching back to Android. Can I install the zip file linked at the top from TWRP?

1 Like

Not sure. The best way would be to use SP Flash with this 10.0.2 full SPFlash Build file.

Note: If you want to preserve TWRP, then uncheck recovery.img in SP Flash.


I’m getting an “AccessDenied” error on that link. Is there another?

1 Like

Oops. Fixed now.

1 Like

Thanks, that works. But I can’t seem to run SP Flash, as its dependency libpng12-0 is no longer available in Ubuntu or POP repos. Can I install any of these with fastboot, like you described here?

1 Like

Yeah you can install the stock firmware using fastboot commands too,

If you were on A10 firmware before flashing GSI/ROM, you can ideally just flash system,vendor & boot images by using following commands
fastboot flash system system.img
fastboot flash vendor vendor.img
fastboot flash boot boot.img
This way it’ll save your custom recovery and you’ll safely land on stock rom.
Warning: your bootloader will NOT be locked by this, if you want to lock bootloader I recommend flashing full ROM via sp flash, just make sure you won’t wipe your IMEI’s ( just don’t use clean all option), also you can install the libpng12-0 packages manually too.


1 Like

Just for reference for anyone else, here’s the method I found that worked for getting libpng12 working on an Ubuntu 22 derivative: